Bug 249211 - Missing user permissions for usb camera (via PTP)
Missing user permissions for usb camera (via PTP)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 249238 249495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 14:26 EDT by Fabian
Modified: 2007-11-30 17:12 EST (History)
9 users (show)

See Also:
Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 09:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel log when I plug in my usb memory stick (1.34 KB, text/plain)
2007-07-28 08:48 EDT, William Lovaton
no flags Details
Screenshot of error dialog on Rawhide i386. (52.45 KB, image/png)
2007-09-04 13:18 EDT, Debarshi Ray
no flags Details

  None (edit)
Description Fabian 2007-07-22 14:26:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
Before updating to kernel 2.6.22.1-27.fc7 connecting a usb camera that uses PTP (not mass storage type), actually Canon EOS 350D, enabled a normal user to access the camera with gphoto2 to import the images to the computer.

After updating to kernel 2.6.22.1-27.fc7 the camera is still recognized and Gnome's automatic action (gthumb-import %h) is triggered. But as normal user (as root it's working) using gthumb-import or digikam to import the images fails with the error message:
"An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Operation not permitted). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device."

Tried to configure udev to change permissions for the coresponding usb device to have permission 0666. But it didn't help.


Booting into kernel 2.6.21-1.3228.fc7 fixes the problem, which makes me believe that the new kernel changes something here.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-27.fc7

How reproducible:
Always


Steps to Reproduce:
1. Login as normal user
2. Connect digital camera via usb (camera using PTP instead of mass storage access)
3. Turn on camera
4. Try to import images on camera with digikam or gthumb-import

Actual Results:
In digikam: error, but no specified error message.
In gthumb-import: error message (s.above)

Expected Results:
Import allowed for normal user, not only for root.

Additional info:
Comment 1 Matti Lehti 2007-07-22 16:03:24 EDT
Is this related to bug id. 248916?
For me gtump-import is unable to connect to Canon Powershot A40 and same happens
with Gnomad2 / Zen Micro.
Both work OK with kernel-2.6.21-1.3228.fc7.
  
Comment 2 Chuck Ebbert 2007-07-23 12:19:26 EDT
CONFIG_USB_DEVICE_CLASS set in FC-6 and F-7 kernel configs.
Will be in the next update, and should fix this bug.
Comment 3 Jarod Wilson 2007-07-24 11:35:47 EDT
*** Bug 249238 has been marked as a duplicate of this bug. ***
Comment 4 Bojan Smojver 2007-07-24 21:26:21 EDT
Do we know the timeframe for this update?
Comment 5 Jarod Wilson 2007-07-24 22:55:17 EDT
Should be in updatest-testing Real Soon Now. The impatient can grab it straight out of koji:

http://koji.fedoraproject.org/packages/kernel/2.6.22.1/33.fc7/
Comment 6 Chuck Ebbert 2007-07-25 10:05:56 EDT
*** Bug 249495 has been marked as a duplicate of this bug. ***
Comment 7 Dennis Björklund 2007-07-27 03:25:36 EDT
Works for me with the new kernel. Thanks.
Comment 8 William Lovaton 2007-07-27 17:15:40 EDT
I don't know if this is the same bug I am seeing but here we go:
When I updated to 2.6.22-27 kernel every time I insert my usb memory stick it
only gets recognized normally as seen in /var/log/messages but it doesn't mount
the drive.  Nautilus doesn't pop up a new window showing the content and it
doesn't appear mounted in 'df'.  The new kernel 2.6.22.1-33.fc7 doesn't fix this
problem either.

The funny thing is that inserting CDs or DVDs works fine and nautilus appears on
the screen showing the content.

If I reboot back to 2.6.21 kernel then everything works fine.  My usb memory
stick gets mounted automatically.
Comment 9 Barry Powell 2007-07-28 03:26:18 EDT
The new kernel 2.6.22.1-33.fc7 has cured the PTP Camera problems, thanks.
Comment 10 Fabian 2007-07-28 04:42:11 EDT
Yes, problem is fixed with kernel 2.6.22.1-33.fc7.

Thanks for this immediate reaction. Great work!
Comment 11 William Lovaton 2007-07-28 08:41:31 EDT
Mmmm... may be the report I made in comment #8 is a different problem, should I
report it in a separate bug?

Can anyone confirm the problem I am seeing?  I just plug in my Trascend 1GB USB
memory into the USB port and it doesn't get mounted, although it gets recognized.

Right now I am using the latest official updates as of today, this is the output
of uname -r:  2.6.22.1-33.fc7

I'll attach the kernel log when I plug my usb memory.
Comment 12 William Lovaton 2007-07-28 08:48:48 EDT
Created attachment 160160 [details]
kernel log when I plug in my usb memory stick

After it gets recognized in the kernel log I check the output of df -h and it
doesn't show there:
[william@localhost ~]$ df -h
Filesystem	      Size  Used Avail Use% Mounted on
/dev/mapper/VGLocal-LVRoot
		       22G   14G  7.8G	64% /
/dev/sda1	       24G   22G  1.9G	93% /media/win
/dev/sda6	       99M   19M   76M	20% /boot
tmpfs		      252M     0  252M	 0% /dev/shm
/dev/sda5	       12G   11G  1.1G	91% /media/media

Some extra information:
- If I boot back to a 2.6.21 kernel everything works fine.
- I can mount the usb driver with mount as root.
- I have tested this on both, my laptop and my desktop computer, same result.
Comment 13 Fabian 2007-07-31 11:01:41 EDT
Am I supposed to close the bug after verifying it?

First bug I submitted here... ;-)
Comment 14 Debarshi Ray 2007-09-04 13:16:57 EDT
I have the same issue with my Olympus C-370Z. However unlike the original
reportee, I am using Rawhide and this bug has been there for the last few weeks.

I can immediately recall having used the following kernels:
kernel-2.6.23-0.105.rc3.git1.fc8
kernel-2.6.23-0.115.rc3.git1.fc8
kernel-2.6.23-0.149.rc4.fc8

Seems like the fix has not been ported to the Rawhide kernel.
Comment 15 Debarshi Ray 2007-09-04 13:18:29 EDT
Created attachment 186351 [details]
Screenshot of error dialog on Rawhide i386.
Comment 16 Debarshi Ray 2007-09-10 09:11:09 EDT
It was a mistake on my part. My camera does not work via PTP, but is detected as
a USB mass storage device.

Sorry for the noise, I am restoring this bug to CURRENTRELASE.
Comment 17 Carl R 2007-11-05 15:38:20 EST
This has stopped working again - error message An error occurred in the
io-library ..>" is the same as before. Please can someone confirm that this bug
hasn't re-emerged... ?
Comment 18 James 2007-11-05 16:06:10 EST
Does /var/lib/hal/acl-list have an entry that looks something like:

/dev/bus/usb/004/006    u       500

(what I see for my PTP camera). Last time I had this problem, acl-list had been
corrupted (so I replaced it with an empty file and restarted haldaemon).
Comment 19 Carl R 2007-11-06 02:14:22 EST
No entries for /dev/bus... in this file, so it must be something else. 

Note You need to log in before you can comment on or make changes to this bug.