Bug 24938 - -pear patch changes the PEAR_INSTALL_DIR to an incorrect directory
Summary: -pear patch changes the PEAR_INSTALL_DIR to an incorrect directory
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 24940 24943 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-25 16:24 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 10:13:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new pear patch that uses /usr/share/php as expected (965 bytes, patch)
2001-01-25 16:50 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff
new pear patch with a non relocable /usr/share/php (also fixes 24943) (985 bytes, patch)
2001-01-25 20:23 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff
-4 spec wich also fixes a small typo (17.78 KB, patch)
2001-01-25 20:27 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff

Description Arenas Belon, Carlo Marcelo 2001-01-25 16:24:14 UTC
for PEAR /usr/share/php ($datadir/php) is used, but this is patch is
incorrectly setting it to
$datadir/php4 (/usr/share/php4) breaking the PEAR.php generation and
posibly making installation harder than it should be

Comment 1 Arenas Belon, Carlo Marcelo 2001-01-25 16:50:31 UTC
Created attachment 8248 [details]
new pear patch that uses /usr/share/php as expected

Comment 2 Arenas Belon, Carlo Marcelo 2001-01-25 19:52:54 UTC
sadly, using $datadir lead to the problem explained on 24943, so this is not a
good solution.

Comment 3 Arenas Belon, Carlo Marcelo 2001-01-25 20:23:21 UTC
Created attachment 8270 [details]
new pear patch with a non relocable /usr/share/php (also fixes 24943)

Comment 4 Arenas Belon, Carlo Marcelo 2001-01-25 20:24:47 UTC
*** Bug 24943 has been marked as a duplicate of this bug. ***

Comment 5 Arenas Belon, Carlo Marcelo 2001-01-25 20:27:12 UTC
Created attachment 8271 [details]
-4 spec wich also fixes a small typo

Comment 6 Nalin Dahyabhai 2001-01-29 20:07:02 UTC
*** Bug 24940 has been marked as a duplicate of this bug. ***

Comment 7 Nalin Dahyabhai 2001-01-29 20:09:57 UTC
Does 4.0.4pl1-4 from Raw Hide fix this problem?

Comment 8 Arenas Belon, Carlo Marcelo 2001-02-05 10:13:09 UTC
nope, there is no fix on the latest -6 from rawhide.

on /usr/share/php/PEAR.php there is a wrong path for :

  define ('PEAR_INSTALL_DIR', '${prefix}/share/php4');

as a result the load of the corresponding Mail subclass on Mail::factory fails
when :

  $classfile = PEAR_INSTALL_DIR. '/Mail/' . $mailer_type. '.php';

Comment 9 Arenas Belon, Carlo Marcelo 2001-03-05 21:38:15 UTC
php-4.0.4pl1-8 used the correct path for pear


Note You need to log in before you can comment on or make changes to this bug.