Bug 249662 - phone Nokia N95 no longer appears as icon in nautilus when connected via USB
phone Nokia N95 no longer appears as icon in nautilus when connected via USB
Status: CLOSED DUPLICATE of bug 249282
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 05:22 EDT by Mario Bruckschwaiger
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 11:55:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Bruckschwaiger 2007-07-26 05:22:28 EDT
Description of problem:
The mobile phone Nokia N95 no longer appears as an icon in the "Computer" view
of nautilus on my i386 when connected via USB cable but it works on my AMD
64-bit Asus laptop. The first difference in hal-device-manager is the key
usb_device.configuration (value: "Buld transfer method configuration") which is
not present on the i386. The next is, that next in the hierarchy of "SCSI
Device" (which has a value of "unknown" for the key "scsi.type") comes "SCSI
Generic Interface". Whereas on the AMD Laptop "SCSI Device" shows a value of
"disk" for key "scsi.device" and the entry "N95" follows the entry of "SCSI
Device" and the next is an entry with the name of the microSD card from the phone.

The output in /var/log/messages is the same on both computers:

Jul 26 11:13:30 rock kernel: usb 1-1: new full speed USB device using uhci_hcd
and address 6
Jul 26 11:13:30 rock kernel: usb 1-1: configuration #1 chosen from 1 choice
Jul 26 11:13:30 rock kernel: scsi11 : SCSI emulation for USB Mass Storage devices
Jul 26 11:13:35 rock kernel: scsi 11:0:0:0: Direct-Access     Nokia    N95     
        1.0  PQ: 0 ANSI: 0
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] 1000215 512-byte hardware
sectors (512 MB)
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] Write Protect is off
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] Assuming drive cache: write through
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] 1000215 512-byte hardware
sectors (512 MB)
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] Write Protect is off
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] Assuming drive cache: write through
Jul 26 11:13:35 rock kernel:  sdc: unknown partition table
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: [sdc] Attached SCSI removable disk
Jul 26 11:13:35 rock kernel: sd 11:0:0:0: Attached scsi generic sg4 type 0


Version-Release number of selected component (if applicable):
hal-libs-0.5.9-8.fc7
hal-gnome-0.5.9-8.fc7
hal-0.5.9-8.fc7
hal-info-20070516-2.fc7
nautilus-2.18.3-1.fc7
udev-106-4.1.fc7

How reproducible:
every time the phone is plugged in via USB cable.

Steps to Reproduce:
1.plug in phone via USB cable
2.
3.
  
Actual results:
no icon in "Comptuer" view of nautilus

Expected results:
icon "N95" in "Computer" view of nautilus

Additional info:
Problem only appears on my i386 computer since a few days ago, but not on my
ASUS 64-bit AMD laptrop with the same software and versions installed.
Comment 1 Mario Bruckschwaiger 2007-07-27 06:47:37 EDT
This bug is not fixed with the latest kernel 2.6.22.1-33.fc7 (bug #249211).
"Normal" USB devices (like a USB memory stick) always worked and work perfectly.
Comment 2 David Zeuthen 2007-07-27 11:55:27 EDT
Sounds like another case of bug 249282.

*** This bug has been marked as a duplicate of 249282 ***

Note You need to log in before you can comment on or make changes to this bug.