Bug 250360 - description in ksh's manpage about subscript of index array is wrong
Summary: description in ksh's manpage about subscript of index array is wrong
Status: CLOSED DUPLICATE of bug 250362
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Keywords:
: 250356 250359 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-01 02:58 UTC by chuli
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 06:15:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch for ksh manpage (340 bytes, patch)
2007-08-01 02:58 UTC, chuli
no flags Details | Diff

Description chuli 2007-08-01 02:58:44 UTC
Description of problem:
The description in ksh's manpage about subscript of index array is wrong.
It says that "The value of all subscripts must be in the range of 0 through 
4095."
In fact, the subscript reach to 16777215.

Version-Release number of selected component (if applicable):
ksh-20060214-1.4

How reproducible:
100%

Steps to Reproduce:
1.man ksh
  
Actual results:
"The value of all subscripts must be in the range of 0 through 4095." will be 
outputed.

Expected results:
"The value of all subscripts must be in the range of 0 through 16777215." will 
be outputed.

Comment 1 chuli 2007-08-01 02:58:44 UTC
Created attachment 160390 [details]
the patch for ksh manpage

Comment 2 Tomas Smetana 2007-08-01 11:09:25 UTC
*** Bug 250356 has been marked as a duplicate of this bug. ***

Comment 3 Tomas Smetana 2007-08-01 11:09:52 UTC
*** Bug 250359 has been marked as a duplicate of this bug. ***

Comment 4 Tomas Smetana 2007-08-03 06:15:44 UTC

*** This bug has been marked as a duplicate of 250362 ***


Note You need to log in before you can comment on or make changes to this bug.