Bug 250362 - description in ksh's manpage about subscript of index array is wrong
description in ksh's manpage about subscript of index array is wrong
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
:
: 250360 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 23:02 EDT by chuli
Modified: 2008-05-21 11:43 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0326
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch for ksh manpage (340 bytes, patch)
2007-07-31 23:02 EDT, chuli
no flags Details | Diff

  None (edit)
Description chuli 2007-07-31 23:02:42 EDT
Description of problem:
The description in ksh's manpage about subscript of index array is wrong.
It says that "The value of all subscripts must be in the range of 0 through 
4095."
In fact, the subscript reach to 16777215.

Version-Release number of selected component (if applicable):
ksh-20060214-1.4

How reproducible:
100%

Steps to Reproduce:
1.man ksh
  
Actual results:
"The value of all subscripts must be in the range of 0 through 4095." will be 
outputed.

Expected results:
"The value of all subscripts must be in the range of 0 through 16777215." will 
be outputed.
Comment 1 chuli 2007-07-31 23:02:51 EDT
Created attachment 160391 [details]
the patch for ksh manpage
Comment 2 Tomas Smetana 2007-08-01 07:04:32 EDT
I'm a bit confused...  This bug was filled three times (bug #250359, bug
#250360) and this one seems to be the latest.  Is this really true for i386
only?  And please keep in mind that ksh scripts are supposed to be portable
among really big number of architectures (even those RHEL won't run on) and the
man page must be really generic.  Two of the three mentioned bugs should be
closed.  Which ones should that be?
Comment 3 Tomas Smetana 2007-08-01 07:08:28 EDT
Oops... Four times: bug #250356 as well.  OK.  I'll close the two of three for
"all" architectures and I would like to ask you whether you could provide any
more detailed info about which of the two remaining to close...
Comment 4 chuli 2007-08-02 21:18:52 EDT
Sorry for duplicated the bug. 
Since when I commit it, a warning message that "Product Name "" is invalid or 
doesnot exist" alwayas outputed, so I tried four times....

This bug is about index subscripts, which has been expanded to 16M. But the 
manpage tells me that it is only 4K.
Comment 5 Tomas Smetana 2007-08-03 02:15:46 EDT
*** Bug 250360 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Smetana 2007-08-03 02:24:16 EDT
I've closed the remainning duplicate and set architecture to "all" on this one.

I know the maximum subscribt value has been increased but originally I thought
that the new limit was 4Mi (not 16Mi). I'll check this with upstream -- the
manpage is wrong in both cases.
Comment 7 RHEL Product and Program Management 2007-10-19 16:27:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Tomas Smetana 2007-11-01 11:49:26 EDT
I've checked the latest beta ksh (2007-10-31) and it says:

The value of all subscripts must be in the range of 0 through 1,048,575.

Let's use that number.
Comment 14 errata-xmlrpc 2008-05-21 11:43:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0326.html

Note You need to log in before you can comment on or make changes to this bug.