Bug 250922 - automount[2281]: open_mount: (mount):cannot open mount module iso9660 (/usr/lib/autofs/mount_iso9660.so: cannot open shared object file: No such file or directory)
automount[2281]: open_mount: (mount):cannot open mount module iso9660 (/usr/l...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
: 390481 (view as bug list)
Depends On:
Blocks: 425943
  Show dependency treegraph
 
Reported: 2007-08-05 06:38 EDT by Peter Bieringer
Modified: 2008-05-21 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2007-08-05 06:38:25 EDT
Seen also on RHEL5

+++ This bug was initially created as a clone of Bug #215767 +++

Description of problem:

Seeing this in the log when there is an attempt to access /misc/cd:

automount[2281]: open_mount: (mount):cannot open mount module iso9660
(/usr/lib/autofs/mount_iso9660.so: cannot open shared object file: No such file
or directory)

The mount still succeeds, so the module appears unnecessary, but it would be
nice to avoid spurrious error messages.

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.22

-- Additional comment from pb@bieringer.de on 2006-12-06 09:08 EST --
Same with mount_cifs.so: 

Dec  6 15:07:44 host automount[2140]: open_mount: (mount):cannot open mount
module cifs (/usr/lib/autofs/mount_cifs.so: cannot open shared object file: No
such file or directory)

-- Additional comment from ikent@redhat.com on 2006-12-06 09:28 EST --
(In reply to comment #1)
> Same with mount_cifs.so: 
> 
> Dec  6 15:07:44 host automount[2140]: open_mount: (mount):cannot open mount
> module cifs (/usr/lib/autofs/mount_cifs.so: cannot open shared object file: No
> such file or directory)

Thanks for reminding me.
This had slipped my mind although I checked the code and
this is more of an informational message in this case than
an actual error.

I'm not sure yet the best way to deal with this because there
are situations where this message should be issued as an error.
I'll think about it a little more.

Ian


-- Additional comment from pb@bieringer.de on 2007-08-05 06:37 EST --
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242084 is probably a dup of
this one.
Comment 1 RHEL Product and Program Management 2007-10-15 23:51:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Ian Kent 2007-11-19 10:29:02 EST
*** Bug 390481 has been marked as a duplicate of this bug. ***
Comment 4 Ian Kent 2007-12-17 04:45:42 EST
The RHTS test bz250922 in the autofs workflow can be used to
verify this bug.

Please use the latest CVS for testing.
Comment 7 errata-xmlrpc 2008-05-21 10:37:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.