Bug 251451 - symlink broken & owned by many packages
symlink broken & owned by many packages
Status: CLOSED DUPLICATE of bug 390171
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: NOMOREXFS
  Show dependency treegraph
 
Reported: 2007-08-09 01:54 EDT by Mamoru TASAKA
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 11:55:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2007-08-09 01:54:01 EDT
Description of problem:
According to http://fedoraproject.org/wiki/Releases/FeatureNoMoreXFS
now some font packages have symlinks in %_sysconfdir/X11/fontpath.d

However on my system some of them are broken and there is a case
that one symlink is owned by many packages

Version-Release number of selected component (if applicable):
(for srpm:) xorg-x11-fonts-ISO8859-1-75dpi

How reproducible:
[root@localhost ~]# pushd /etc/X11/fontpath.d/
/etc/X11/fontpath.d ~ ~

[root@localhost fontpath.d]# LANG=C ls -al
total 40
drwxr-xr-x  2 root root 4096 Jun 28 03:13 .
drwxr-xr-x 18 root root 4096 Aug  7 13:41 ..
lrwxrwxrwx  1 root root   36 Jun 28 03:13 fonts-default ->
/usr/share/fonts/default/ghostscript
lrwxrwxrwx  1 root root   35 Jun 26 14:02 xorg-x11-fonts-75dpi:unscaled:pri=20
-> /usr/share/X11/fonts/75dpi:unscaled
lrwxrwxrwx  1 root root   36 Jun 26 14:02 xorg-x11-fonts-100dpi:unscaled:pri=30
-> /usr/share/X11/fonts/100dpi:unscaled
lrwxrwxrwx  1 root root   24 Jun 26 14:01 xorg-x11-fonts-TTF ->
/usr/share/X11/fonts/TTF
lrwxrwxrwx  1 root root   26 Jun 26 14:01 xorg-x11-fonts-Type1 ->
/usr/share/X11/fonts/Type1
lrwxrwxrwx  1 root root   34 Jun 26 14:00 xorg-x11-fonts-misc:unscaled:pri=10 ->
/usr/share/X11/fonts/misc:unscaled
[root@localhost fontpath.d]# LANG=C ls -al '/usr/share/X11/fonts/75dpi:unscaled'
'/usr/share/X11/fonts/100dpi:unscaled' '/usr/share/X11/fonts/misc:unscaled'
ls: cannot access /usr/share/X11/fonts/75dpi:unscaled: No such file or directory
ls: cannot access /usr/share/X11/fonts/100dpi:unscaled: No such file or directory
ls: cannot access /usr/share/X11/fonts/misc:unscaled: No such file or directory
[root@localhost fontpath.d]# rpm -qf 'xorg-x11-fonts-75dpi:unscaled:pri=20'
xorg-x11-fonts-ISO8859-15-75dpi-7.2-1.fc8
xorg-x11-fonts-75dpi-7.2-1.fc8
xorg-x11-fonts-ISO8859-1-75dpi-7.2-1.fc8
xorg-x11-fonts-ISO8859-14-75dpi-7.2-1.fc8
[root@localhost fontpath.d]# rpm -qf 'xorg-x11-fonts-100dpi:unscaled:pri=30'
xorg-x11-fonts-ISO8859-14-100dpi-7.2-1.fc8
xorg-x11-fonts-ISO8859-15-100dpi-7.2-1.fc8
xorg-x11-fonts-100dpi-7.2-1.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-1.fc8

Here 3 symlinks are broken, and more that one package own
one symlink.
  

Expected results:
* symlinks must not be broken
* one symlinks must be owned by only one package
Comment 1 Mamoru TASAKA 2007-08-09 01:55:59 EDT
(In reply to comment #0)
> Version-Release number of selected component (if applicable):
> (for srpm:) xorg-x11-fonts-ISO8859-1-75dpi

Oops.. this is xorg-x11-fonts-7.2-1.fc8
Comment 2 Mamoru TASAKA 2007-08-15 13:15:40 EDT
Also, xorg-x11-fonts related packages should not own
the directory /etc/X11/fontpath.d itself (bug 251707)
Comment 3 Mamoru TASAKA 2007-09-19 12:33:12 EDT
ping? IMO this must be fixed before F8T3.
Comment 4 Adam Jackson 2007-09-25 11:55:11 EDT
They're not real symlinks.  They only exist to be readlink()'d, not to be
followed.  That the :unscaled symlinks don't point to real directories is not a bug.

Likewise, it's completely correct that multiple packages own some of the
symlinks.  Multiple packages install into the target directories, and need to
make sure the symlinks exist so that their fonts get picked up.

This isn't a bug.  It's by design.
Comment 5 Matěj Cepl 2007-11-21 05:52:33 EST

*** This bug has been marked as a duplicate of 390171 ***

Note You need to log in before you can comment on or make changes to this bug.