Bug 390171 - Broken links in /etc/X11/fontpath.d/
Summary: Broken links in /etc/X11/fontpath.d/
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 251451 388921 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-19 10:13 UTC by Frank Eisenmenger
Modified: 2018-04-11 08:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 19:05:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Eisenmenger 2007-11-19 10:13:49 UTC
Description of problem:

on fully installed & updated i386 & x86_64 Fedora 8 systems, I found the 
following links BROKEN in /etc/X11/fontpath.d/

xorg-x11-fonts-100dpi:unscaled:pri=30 -> 
/usr/share/X11/fonts/100dpi:unscaled
xorg-x11-fonts-misc:unscaled:pri=10 -> /usr/share/X11/fonts/misc:unscaled


This may be caused by incorrect installation scripts of

xorg-x11-fonts-misc-7.2-3.fc8
xorg-x11-fonts-100dpi-7.2-3.fc8

RPMs.


A workaround is to add:

Section "Files"
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/misc:unscaled"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
EndSection

to /etc/X11/xorg.conf


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2007-11-19 10:33:30 UTC
Yup, and xorg-x11-fonts-75dpi:unscaled:pri=30 as well.

Comment 2 Matěj Cepl 2007-11-19 15:50:32 UTC
*** Bug 388921 has been marked as a duplicate of this bug. ***

Comment 3 Kristian Høgsberg 2007-11-19 19:05:22 UTC
Fixed in 7.2-4, thanks.

Comment 4 Mamoru TASAKA 2007-11-20 07:30:57 UTC
???

I have reported this bug more than 3 months ago (bug 251451),
bug it was closed with NOTABUG by ajax. What happened here?

Comment 5 Kristian Høgsberg 2007-11-20 16:55:59 UTC
Oh, oops.  I guess Adam closed it a little too fast, sorry about that.

Comment 6 Matěj Cepl 2007-11-21 10:52:34 UTC
*** Bug 251451 has been marked as a duplicate of this bug. ***

Comment 7 Nicole Dai 2008-01-15 10:13:17 UTC
Verified the three broken links have been fixed in xorg-x11-fonts-*-7.2-4.fc9

Comment 8 matt cowan 2008-04-16 15:58:18 UTC
so this has been fixed for months and no update released for f8!?


Comment 9 matt cowan 2008-04-16 17:07:10 UTC
and I can't even just do
  yum --enablerepo=development update xorg-x11-fonts-75dpi
or even
  yum --enablerepo=development upgrade xorg-x11-fonts-75dpi
!!!
...
Transaction Check Error:
  file /etc/X11/fontpath.d/xorg-x11-fonts-75dpi:unscaled:pri=20 from install of
xorg-x11-fonts-75dpi-7.2-6.fc9.noarch conflicts with file from package
xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8.noarch
...

and of course there are dependencies on these font packages, so I can't simply
rpm -e them without --nodeps, which is just asking for even more trouble.  I
even needed --noscripts to finally get rid of the 75dpi, 100dpi, and misc font
packages.  but all to no avail as yum update|upgrade|install still exit
with the same file conflict error as above!?  figures.

Either this bug should not be closed, or some other bugs need to be opened?


Comment 10 Mamoru TASAKA 2008-04-16 17:47:35 UTC
(In reply to comment #9)
> and I can't even just do
>   yum --enablerepo=development update xorg-x11-fonts-75dpi
> or even
>   yum --enablerepo=development upgrade xorg-x11-fonts-75dpi
> !!!
> ...
> Transaction Check Error:
>   file /etc/X11/fontpath.d/xorg-x11-fonts-75dpi:unscaled:pri=20 from install of
> xorg-x11-fonts-75dpi-7.2-6.fc9.noarch conflicts with file from package
> xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8.noarch

This is due to bug 251451 (owned by many packages)


Note You need to log in before you can comment on or make changes to this bug.