Bug 251691 - enable lesstif for EPEL
enable lesstif for EPEL
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
: lesstif-epel 470878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-10 09:29 EDT by Balint Cristian
Modified: 2008-12-16 10:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 10:06:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs-


Attachments (Terms of Use)

  None (edit)
Description Balint Cristian 2007-08-10 09:29:36 EDT
Package Change Request
======================
Package Name: lesstif
New Branches: EL-4 EL-5
Comment 1 Kevin Fenzi 2007-08-10 12:54:50 EDT
Can we get an ack from Patrice here? 
Patrice: Do you want to maintain this in EPEL?
(reset fedora-cvs when ready)
Comment 2 Patrice Dumas 2007-08-10 13:00:23 EDT
Why not use openmotif in EPEL?
Comment 3 Balint Cristian 2007-08-10 13:18:46 EDT
Good point !

Forgot about this ...
I try, if i fail i'll ping you.
Comment 4 Patrice Dumas 2007-08-10 13:22:26 EDT
This was discussed when lesstif was introduced instead of openmotif in 
fedora, but never done. Maybe to ease things it could be possible to have
a virtual provide for a motif interface, such that there is a requires
for the devel package like 

BuildRequires: Motif-devel(2)
Comment 5 Hans de Goede 2007-09-02 14:15:24 EDT
(In reply to comment #4)
> This was discussed when lesstif was introduced instead of openmotif in 
> fedora, but never done. Maybe to ease things it could be possible to have
> a virtual provide for a motif interface, such that there is a requires
> for the devel package like 
> 
> BuildRequires: Motif-devel(2)

Sounds like a plan to me, what is stopping us?
Comment 6 Patrice Dumas 2007-09-11 05:09:09 EDT
When I asked about coordination with RHEL on the EPEL list, 
to know what will be in next RHEL I got the answer:

"what Red Hat Does for RHEL is up to Red Hat to decide.  
So to answer your question we will
know what the status is when RHEL6 lands."

which sadly doesn't incitate a lot to cooperation. It
even irritates me, but, well... Next mails in thread were
a bit more friendly, but nobody from redhat seems to 
care about cooperating with EPEL/Fedora on this issue.
Comment 7 Patrice Dumas 2008-03-18 17:09:01 EDT
*** Bug 438071 has been marked as a duplicate of this bug. ***
Comment 8 Patrice Dumas 2008-03-18 17:13:55 EDT
I also sent a mail to riek at fedora dot com, on Nov 2, about
cooperation regarding the lesstif/openmotif packaging, but never
got an answer.


That was the mail content:

I am the lesstif maintainer in fedora, and I also maintain or use some
packages that depend on a motif implementation (in fedora and EPEL).
As you may (or may not) know, lesstif is used in fedora instead of
openmotif because openmotif is not considered free enough -- although it
is agreed that openmotif is a better implementation -- since fedora 6
(if I recall well). If I recall well, RHEL comes more or less from a mix
of F-5 and F-6, so in RHEL 4 and 5 the motif implementation is
openmotif.

But what about the future? Will RHEL 6 come with lesstif like fedora, or
stick with openmotif, since it is better? If RHEL sticks to openmotif,
then I think that it would be nice if we could cooperate to devise
virtual provides for the motif interface, such that building packages
for RHEL (in EPEL, for example) or in fedora isn't associated with
different BuildRequires (as it is currently).
Comment 9 Bug Zapper 2008-05-13 23:07:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Patrice Dumas 2008-11-10 13:29:54 EST
*** Bug 470878 has been marked as a duplicate of this bug. ***
Comment 11 Hans de Goede 2008-12-16 10:06:20 EST
Hi all,

Short intro: Patrice is stepping down as maintainer of lesstif and I'm the new maintainer.  RHEL will probably always contain openmotif as various third party applications need a motif binary compatible with the original (*). So I see little reason to include lesstif in EPEL, not to mention that there will probably be conflicts which need fixing if we do.

So I'm closing this, I'm not going to stop anyone who really wants it to create a lesstif package for EPEL which is parallel installable to openmotif, but I'm not going to do it.

*) This is my personal opinion / estimation and in no way reflects my employers take on this (I'm not in a team which is directly involved with openmotif and have no internal knowledge about any plans surrounding openmotif).

Note You need to log in before you can comment on or make changes to this bug.