Bug 251815 - udev after update complains "unknown format variable"
udev after update complains "unknown format variable"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 252168 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-11 16:40 EDT by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: udev-114-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 04:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first screen from oops with 2.6.22.1-32.fc6 (103.59 KB, image/jpeg)
2007-08-11 18:45 EDT, Michal Jaegermann
no flags Details
second screen from oops with 2.6.22.1-32.fc6 (82.97 KB, image/jpeg)
2007-08-11 18:46 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-08-11 16:40:50 EDT
Description of problem:

After an update to udev-114-1.fc8 I see the following while booting:

Starting udev: udevd-event[966]: udev_rules_apply_format: unknown format
variable '$(while read id; do echo pnp:d$$id; done < /sys$devpath/id)''
udevd-event[967]: udev_rules_apply_format: unknown format variable '$(while read
id; do echo pnp:d$$id; done < /sys$devpath/id)''
udevd-event[968]: udev_rules_apply_format: unknown format variable '$(while read
id; do echo pnp:d$$id; done < /sys$devpath/id)''
udevd-event[979]: udev_rules_apply_format: unknown format variable '$(while read
id; do echo pnp:d$$id; done < /sys$devpath/id)''
udevd-event[986]: udev_rules_apply_format: unknown format variable '$(while read
id; do echo pnp:d$$id; done < /sys$devpath/id)''
udevd-event[987]: udev_rules_apply_format: unknown format variable '$(while read
id; do echo pnp:d$$id; done < /sys$devpath/id)''
udevd-event[992]: udev_rules_apply_format: unknown format variable '$(while read
id; do echo pnp:d$$id; done < /sys$devpath/id)''

and so on ....  That is with kernel 2.6.23-0.74.rc2.git1.fc8 as
2.6.23-0.96.rc2.git2.fc8 does not boot.

After that things seems to be in a runnable state (although maybe
I am just lucky with my hardware config?).

Version-Release number of selected component (if applicable):
udev-114-1.fc8
Comment 1 Michal Jaegermann 2007-08-11 17:10:52 EDT
> 2.6.23-0.96.rc2.git2.fc8 does not boot.
See bug 251816.
Comment 2 Michal Jaegermann 2007-08-11 18:45:27 EDT
Created attachment 161124 [details]
first screen from oops with 2.6.22.1-32.fc6

With a help of 'boot_delay=200' I took pictures of both exception
screens for 2.6.22.1-32.fc6.  It says "invalid opcode" at the beginning.
Comment 3 Michal Jaegermann 2007-08-11 18:46:11 EDT
Created attachment 161125 [details]
second screen from oops with 2.6.22.1-32.fc6
Comment 4 Michal Jaegermann 2007-08-11 18:49:47 EDT
Oops!  Scratch attachments from comments 2 and 3.  They are ok, but
for another bug.
Comment 5 Tom London 2007-08-12 12:47:03 EDT
Get this too.  Could it be from 80-drivers.rules:

[root@localhost rules.d]# cat 80-drivers.rules 
# do not edit this file, it will be overwritten on update

ACTION!="add", GOTO="drivers_end"

DRIVER!="?*", ENV{MODALIAS}=="?*", RUN{ignore_error}+="/sbin/modprobe
$env{MODALIAS}"
SUBSYSTEM=="pnp", DRIVER!="?*", ENV{MODALIAS}!="?*", \
  RUN{ignore_error}+="/bin/sh -c '/sbin/modprobe -a $(while read id; do echo
pnp:d$$id; done < /sys$devpath/id)'"
SUBSYSTEM=="tifm", RUN+="/sbin/modprobe --all tifm_sd tifm_ms"
SUBSYSTEM=="mmc", RUN+="/sbin/modprobe mmc_block"
SUBSYSTEM=="ide", ATTR{media}=="tape", RUN+="/sbin/modprobe ide-scsi"
SUBSYSTEM=="scsi_device", TEST!="[module/sg]", RUN+="/sbin/modprobe sg"

LABEL="drivers_end"

[root@localhost rules.d]# 
Comment 6 Michal Jaegermann 2007-08-13 15:02:58 EDT
> Could it be from 80-drivers.rules ...

Replacing in this file both single quotes on RUN line with \" at 
least shuts down all that noise.
Comment 7 Harald Hoyer 2007-08-14 05:55:44 EDT
correct fix, as in the newest version: "$$(" instead of "$("
Comment 8 Harald Hoyer 2007-08-14 09:02:33 EDT
*** Bug 252168 has been marked as a duplicate of this bug. ***
Comment 9 Harald Hoyer 2007-08-14 09:23:59 EDT
fixed in udev-114-2.fc8

Note You need to log in before you can comment on or make changes to this bug.