Bug 252378 - traceback doing 'yum install gcc' with an updated glibc available
traceback doing 'yum install gcc' with an updated glibc available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 253376 271361 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-08-15 13:42 EDT by Giuliano Marco
Modified: 2014-01-21 17:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 13:28:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Giuliano Marco 2007-08-15 13:42:53 EDT
Pirut crashed trying to install gcc on Fedora 8 (7.9) Test 1 AMD64. gcc is
required to get vmtools compiled/working. The built-in vmware driver only shows
800x600 and 640x480 modes. I want full-screen mode 10, 1680x1050. Running Fedora
in a VMware session on Vista 64.

Additional info:

Component: pirut
Summary: TB8a9b4f2f packageSack.py:600:returnNewestByNameArch:PackageSackError:
No Package Matching glibc.i686

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 337, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 734, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 493, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 453, in
_requiringFromInstalled
    po = self.pkgSack.returnNewestByNameArch((name,arch))[0]
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 308, in
returnNewestByNameArch
    return bestofeach.returnNewestByNameArch(naTup)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 600, in
returnNewestByNameArch
    raise PackageSackError, 'No Package Matching %s.%s' % naTup
PackageSackError: No Package Matching glibc.i686

Local variables in innermost frame:
highdict: {}
self: <yum.packageSack.ListPackageSack object at 0x6860d10>
naTup: ('glibc', 'i686')
where: None
Comment 1 Jeremy Katz 2007-08-20 14:03:56 EDT
*** Bug 253376 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2007-08-21 13:28:57 EDT
Fixed in yum for yum 3.2.3
Comment 3 Jeremy Katz 2007-08-31 14:35:16 EDT
*** Bug 271361 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.