Bug 253376 - Unhandled exception trying to install glibc for x86_64
Unhandled exception trying to install glibc for x86_64
Status: CLOSED DUPLICATE of bug 252378
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-18 10:48 EDT by Giuliano Marco
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-20 14:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Giuliano Marco 2007-08-18 10:48:46 EDT
Description of problem:
Can't use Package/Software Manager (or Yum) to install glibc for x86_64. I 
need gcc to be able to compile the Nvidia kernel for the latest 100.14.11 
binary driver. This is on a fresh install of F7 KDE (for AMD64).

Exception Occured error dump:

Component: Software Manager
Summary: TB8a9b4f2f 
packageSack.py:600:returnNewestByNameArch:PackageSackError: No Package 
Matching glibc.i686

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 337, in _apply
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 718, in 
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 481, in 
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 549, in 
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 853, in 
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 337, in 
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 456, in 
    po = self.pkgSack.returnNewestByNameArch((name,arch))[0]
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 308, in 
    return bestofeach.returnNewestByNameArch(naTup)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 600, in 
    raise PackageSackError, 'No Package Matching %s.%s' % naTup
PackageSackError: No Package Matching glibc.i686

Local variables in innermost frame:
highdict: {}
self: <yum.packageSack.ListPackageSack object at 0x681bc50>
naTup: ('glibc', 'i686')
where: None
Comment 1 Giuliano Marco 2007-08-19 05:48:31 EDT
I think I might have found a way around it. I tried doing this in a console...

yum install glibc
yum install gcc

... and it seemed to work. The gcc wouldn't install unless glibc had been 
installed or updated first. I managed to get the Nvidia driver working after 

Associated with bug #232378
Comment 2 Jeremy Katz 2007-08-20 14:03:52 EDT

*** This bug has been marked as a duplicate of 252378 ***

Note You need to log in before you can comment on or make changes to this bug.