Bug 253041 - 2.6.22.2-57.fc7 cannot load bcm43xx_microcode5.fw
2.6.22.2-57.fc7 cannot load bcm43xx_microcode5.fw
Status: CLOSED DUPLICATE of bug 252983
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 14:08 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 09:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-08-16 14:08:32 EDT
Description of problem:

With 2.6.22.2-57.fc7 from updates-testing:

b43-phy0 debug: Adding Interface type 2
b43-phy0 ERROR: Microcode "bcm43xx_microcode5.fw" not available or load failed.
b43-phy0 ERROR: You must go to
http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the
correct firmware (version 4)

Which I did and installed:

[root@cynosure ~]# ls -l /lib/firmware
total 256
-rw-r--r-- 1 root root  3720 2007-08-16 10:57 bcm43xx_initval01.fw
-rw-r--r-- 1 root root    16 2007-08-16 10:57 bcm43xx_initval02.fw
-rw-r--r-- 1 root root  3720 2007-08-16 10:57 bcm43xx_initval03.fw
-rw-r--r-- 1 root root    16 2007-08-16 10:57 bcm43xx_initval04.fw
-rw-r--r-- 1 root root  2592 2007-08-16 10:57 bcm43xx_initval05.fw
-rw-r--r-- 1 root root   248 2007-08-16 10:57 bcm43xx_initval06.fw
-rw-r--r-- 1 root root  2592 2007-08-16 10:57 bcm43xx_initval07.fw
-rw-r--r-- 1 root root  2592 2007-08-16 10:57 bcm43xx_initval08.fw
-rw-r--r-- 1 root root   248 2007-08-16 10:57 bcm43xx_initval09.fw
-rw-r--r-- 1 root root   248 2007-08-16 10:57 bcm43xx_initval10.fw
-rw-r--r-- 1 root root  2864 2007-08-16 10:57 bcm43xx_initval20.fw
-rw-r--r-- 1 root root   248 2007-08-16 10:57 bcm43xx_initval21.fw
-rw-r--r-- 1 root root  2872 2007-08-16 10:57 bcm43xx_initval22.fw
-rw-r--r-- 1 root root   248 2007-08-16 10:57 bcm43xx_initval23.fw
-rw-r--r-- 1 root root  2872 2007-08-16 10:57 bcm43xx_initval24.fw
-rw-r--r-- 1 root root   248 2007-08-16 10:57 bcm43xx_initval25.fw
-rw-r--r-- 1 root root 26592 2007-08-16 10:57 bcm43xx_microcode11.fw
-rw-r--r-- 1 root root 24416 2007-08-16 10:57 bcm43xx_microcode13.fw
-rw-r--r-- 1 root root 20072 2007-08-16 10:57 bcm43xx_microcode4.fw
-rw-r--r-- 1 root root 22080 2007-08-16 10:57 bcm43xx_microcode5.fw
-rw-r--r-- 1 root root  1312 2007-08-16 10:57 bcm43xx_pcm4.fw
-rw-r--r-- 1 root root  1312 2007-08-16 10:57 bcm43xx_pcm5.fw


to no avail.
Comment 1 Orion Poplawski 2007-08-16 14:13:50 EDT
Looks like we've changed some drivers:

/lib/modules/2.6.22.2-57.fc7/kernel/drivers/net/wireless/bcm43xx
/lib/modules/2.6.22.2-57.fc7/kernel/drivers/net/wireless/bcm43xx/bcm43xx.ko
/lib/modules/2.6.22.2-57.fc7/kernel/drivers/net/wireless/b43
/lib/modules/2.6.22.2-57.fc7/kernel/drivers/net/wireless/b43/b43.ko

/lib/modules/2.6.22.2-52.fc7/kernel/drivers/net/wireless/bcm43xx
/lib/modules/2.6.22.2-52.fc7/kernel/drivers/net/wireless/bcm43xx/bcm43xx.ko
/lib/modules/2.6.22.2-52.fc7/kernel/drivers/net/wireless/bcm43xx-mac80211
/lib/modules/2.6.22.2-52.fc7/kernel/drivers/net/wireless/bcm43xx-mac80211/bcm43xx-mac80211.ko
Comment 2 John W. Linville 2007-08-16 14:26:37 EDT
The driver rename is not a problem -- clearly the MODULE_ALIAS is working or 
you would not have hit this problem. :-)

What is the source of your firmware?
Comment 3 Orion Poplawski 2007-08-16 14:34:27 EDT
(In reply to comment #2)
> What is the source of your firmware?

broadcom-wl-4.80.53.0.tar.bz2 from the linuxwireless.org site.  The same set
works fine with the latest rawhide kernel.
Comment 4 John W. Linville 2007-08-16 14:37:02 EDT
Hmmm...the b43 bits in both F7 and rawhide are the same...
Comment 5 Michael Buesch 2007-08-16 15:05:49 EDT
Note the "or load failed." part of the message.
So the message not only means that it wasn't found, but it's also possible to be
caused by something else. Like Could not read file, or missing fw support in the
kernel. What's the error code returned from ifconfig (or ip)?
Comment 6 Sammy 2007-08-17 09:45:51 EDT
Must be the same as bug#252983 with udev,
Comment 7 John W. Linville 2007-08-17 09:57:01 EDT
Closing under the presumption that "udev-113-11.fc7 fixes" (from bug 252983 
comment 1).

*** This bug has been marked as a duplicate of 252983 ***

Note You need to log in before you can comment on or make changes to this bug.