Bug 26435 - netscape script no longer opens new windows from already running browser
Summary: netscape script no longer opens new windows from already running browser
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 26442 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 06:09 UTC by Douglas Kilpatrick
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 06:20:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Douglas Kilpatrick 2001-02-07 06:09:12 UTC
netscape script no longer opens new windows from already running browser. 
Instead, the "lock file detected?  Continue?" netscape dialog comes up if
you try and run netscape when an instance of netscape is already running.

Should line 91 be "if [ -z "$MOZ_PIDS" ];" instead of skipping the '$'
character?  I made the change locally and it seems to work fine now.

Comment 1 Bill Nottingham 2001-02-07 06:20:11 UTC
Yup.

*** This bug has been marked as a duplicate of 25160 ***

Comment 2 Bill Nottingham 2001-02-07 06:20:48 UTC
Oops, I can't close it like that. Fixed in 4.76-7.

Comment 3 Douglas Kilpatrick 2001-02-07 06:33:26 UTC
Same bug subject in 4.76-7, different cause.  Any reason you only try and
connect to the running browser if its called "mozilla" now?

Comment 4 Douglas Kilpatrick 2001-02-07 06:44:31 UTC
Er, retract last comment.  Sorry.  Its still not working right (still triest to
run netscape a second time), but I have not yet figured out exactly why.

Comment 5 Bill Nottingham 2001-02-07 07:06:21 UTC
Oops, fixed in -9.

The general problem is that if mozilla is running, you can't
use:

  netscape -remote 'xfeDoCommand(whatever)'.


Comment 6 Bill Nottingham 2001-02-07 08:14:12 UTC
*** Bug 26442 has been marked as a duplicate of this bug. ***

Comment 7 Douglas Kilpatrick 2001-03-14 13:47:47 UTC
$ rpm -q -a | grep netscape
netscape-common-4.76-10
netscape-navigator-4.76-10

which are the versions in the March 10 rawhide:

Now running netscape again gives you a new netscape window reliably.
It just kills any old netscape-windows too...  not good.


Comment 8 Bill Nottingham 2001-03-14 16:03:16 UTC
You're using KDE, right?

KDE is odd. A workaround is in the -11 pacakges.


Note You need to log in before you can comment on or make changes to this bug.