Bug 26444 - shutdown -r don't reboot, halt only
Summary: shutdown -r don't reboot, halt only
Status: CLOSED DUPLICATE of bug 19743
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard: Florence Gold
Keywords:
: 28602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 08:38 UTC by Igor
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-03 07:50:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The messages log, from the point the shutdown -r now commaned is issued to the point were X is up an running. (25.94 KB, text/plain)
2002-06-03 19:22 UTC, don.tiller
no flags Details

Description Igor 2001-02-07 08:38:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


same as #19743

Reproducible: Always
Steps to Reproduce:
1.shutdown -r now
2.
3.
	

Actual Results:  halt

Expected Results:  reboot

Comment 1 Glen Foster 2001-02-08 16:01:01 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Need Real Name 2001-02-08 16:20:34 UTC
Thanks,
But how can we do before the next release? and when did she available?
Christophe

Comment 3 Michael K. Johnson 2001-02-09 00:35:02 UTC

*** This bug has been marked as a duplicate of 26261 ***

Comment 4 Igor 2001-03-19 14:43:46 UTC
The same in wolverine with kernel from rawhide.

Comment 5 Arjan van de Ven 2001-03-21 13:11:51 UTC
Can you try adding one of the following items to lilo.conf as append= ?

 reboot=c
 reboot=h
 reboot=b
 reboot=w



Comment 6 Arjan van de Ven 2001-03-21 18:25:58 UTC
*** Bug 28602 has been marked as a duplicate of this bug. ***

Comment 7 Igor 2001-03-23 09:52:20 UTC
Yes.
kernel-2.4.2-0.1.25.i686.rpm don't reboot
but kernel-2.4.2-0.1.28.i686.rpm reboot without appends.

Comment 8 Arjan van de Ven 2001-03-23 15:07:21 UTC
Weird.
Since recent kernels work again, I'll close this. But please reopen if 
the problem comes back again.

Comment 9 Igor 2001-04-26 05:50:07 UTC
Kernel in RH7.1 don't reboot again.

Comment 10 Arjan van de Ven 2001-04-26 08:44:50 UTC
Can you try adding "reboot=b" on the lilo prompt and see if you can reboot ?
This option seems to be the best bet in getting it to work.

Comment 11 Igor 2001-04-27 13:52:58 UTC
The same. Don't reboot too.

Comment 12 don.tiller 2002-06-03 19:22:52 UTC
Created attachment 59424 [details]
The messages log, from the point the shutdown -r now commaned is issued to the point were X is up an running.

Comment 13 don.tiller 2002-06-03 19:23:55 UTC
I have been experiencing the same or a very similar problem using the 2.4.18-4smp (and 2.4.18-3smp) kernel. The last line displayed on the 
screen when going through the shut-down / reboot process is (shutdown -r now)

(<c0108c5b>) system_call [kernel] 0x33
code: f0 fe 08 0f 88 9c 1d 00 00 80 bb 05 01 00 00 00 75 19 8b 54
INIT: no more processes left in this run level

at which point it hangs. Issueing a ctrl-alt-del at this point will return the line

shutdown: warning: cannot open /var/run/shutdown.pid

According to the messages log the shutdown worked fine but nothing happens until the machine is reset.

When using the 2.4.18-4 (or 2.4.18-3) kernel everything works great.

Comment 14 Igor 2002-06-04 13:18:12 UTC
RH 7.3 kernel-2.4.18-3.i686.rpm don't reboot PC.
What is difference between kernel-2.4.2-0.1.25.i686.rpm and
kernel-2.4.2-0.1.28.i686.rpm? May be it help to understand reason of error.

Comment 15 Igor 2002-12-03 07:50:41 UTC
RH 8.0 kernel 2.4.18-14 reboots correctly.

Comment 16 Igor 2002-12-05 06:53:22 UTC

*** This bug has been marked as a duplicate of 19743 ***


Note You need to log in before you can comment on or make changes to this bug.