Bug 27137 - gcc-2.96-74 Internal compiler error in replace_reg
Summary: gcc-2.96-74 Internal compiler error in replace_reg
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 28852 30935 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-12 12:53 UTC by Michele Baldessari
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 23:14:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michele Baldessari 2001-02-12 12:53:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.1 i686)


While trying to compile the Crystal Space 3d engine
(crystal.sourceforge.net) cvs
snapshot of today (2001-02-12) the compiler (2.96-74) vails out with an
internal compiler error
gcc-2.96-74 bails out with :
gcc -c -o out/LINUX/INTEL/optimize/camera.o libs/csengine/camera.cpp -Wall
-Wunused -W -mpentiumpro -march=i686 -fno-exceptions -fno-rtti -O6
-fomit-frame-pointer -ffast-math -I. -I./apps -I./include -I./libs
-I./plugins -I./support
libs/csengine/camera.cpp: In method `void csCamera::LookAt (const
csVector3 &, const csVector3 &)':
libs/csengine/camera.cpp:163: Internal compiler error in replace_reg,
at reg-stack.c:830


Reproducible: Always
Steps to Reproduce:
1. Fetch the (2000-02-12) CVS snapshot from crystal.sourceforge.net
2. make linux USE_PLUGINS=yes 
3. make all
	

Actual Results:  gcc -c -o out/LINUX/INTEL/optimize/camera.o
libs/csengine/camera.cpp -Wall -Wunused -W -mpentiumpro -march=i686
-fno-exceptions -fno-rtti -O6
-fomit-frame-pointer -ffast-math -I. -I./apps -I./include -I./libs
-I./plugins -I./support
libs/csengine/camera.cpp: In method `void csCamera::LookAt (const
csVector3 &, const csVector3 &)':
libs/csengine/camera.cpp:163: Internal compiler error in replace_reg,
at reg-stack.c:830


Expected Results:  :-)

If you need further info contact me. (mbaldessari@redhat.it)

Comment 1 Glen Foster 2001-02-12 23:14:41 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Jakub Jelinek 2001-02-13 12:59:09 UTC
qsqrt.h header there has bogus __asm constraints, gcc used to crash on bogus
__asm constraints all the time so I don't want to spend time on this.
I've submitted bug for crystal space instead.

Comment 3 Michele Baldessari 2001-02-13 23:04:00 UTC
Agreed that it is a bogus __asm constraint. Isn't there a chance to make it 
not crash, instead of giving an internal compiler error?
(I'm just thinking of the wave of complaints 2.96Rh blablabla I'll have to 
face :-)
Thanks anyway for the quick response

Comment 4 Jakub Jelinek 2001-02-22 16:37:43 UTC
*** Bug 28852 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Jelinek 2001-03-12 16:19:49 UTC
*** Bug 30935 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.