Bug 2744 - tulip.c driver not current, fails with DC21142 chip
tulip.c driver not current, fails with DC21142 chip
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 3453 3532 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-11 15:11 EDT by del
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description del 1999-05-11 15:11:39 EDT
The tulip.c driver in drivers/net is version 0.89H.
I had to download the version 0.91 driver in order
to get my Kingston Tulip-based KNE100TX ethernet card to
work.  The older driver recognized the card as a
Tulip chip card, but did not operate correctly.

/proc/pci reports a DEC DC21142 (rev 65) chip.
Comment 1 Jay Turner 1999-05-19 14:52:59 EDT
We do not have one of these cards in the test lab inventory, but I
will forward this request to the install guys and make sure that the
new version of the driver gets put in the tree.
Comment 2 Alan Cox 1999-06-12 23:03:59 EDT
It isnt that simple. Don's driver doesn't have some stuff that is part
of the kernel driver. Thats where this mess about two tulip revs comes
from. Don doesnt like the fastroute stuff, but its important for folks
doing high speed routing 8(
Comment 3 Jeff Johnson 1999-06-14 13:32:59 EDT
*** Bug 3453 has been marked as a duplicate of this bug. ***

I have noticed with all users running Hedwig that some
network cards based off the Tulip driver (most notably
LinkSys EtherFast cards) do not function.  This is
characterized by a lack of network card initialization at
startup, followed by an inability to open eth0 (and the
message "Delayed eth0 initialization").  In addition to
that, issuing "insmod tulip" returns only that the device is
busy and does not elaborate.  Both the standard tulip.c
within the kernel and the LinkSys-provided tulip.c have been
tested, and both have returned the same results.  The only
conclusion that I can arrive at is that Hedwig contains some
sort of bug which interferes with the operation of
Tulip-based cards; it is also notable that such activity is
not present in Apollo.

------- Additional Comments From nrhudy@pabus.com  06/14/99 09:59 -------
By the way, I forgot to mention that I have been reading reports of
similar happenings on LinkSys mailing lists and the like, if that
helps any.
Comment 4 nrhudy 1999-06-14 18:37:59 EDT
/proc/pci only recognizes my board as being an NE2000-compatible
board.  However, using the NE2000 drivers does not provide any
networking functionality.

  Bus  0, device  15, function  0:
    Ethernet controller: Winbond NE2000-PCI (rev 0).
      Medium devsel.  Fast back-to-back capable.  IRQ 10.
      I/O at 0x1060 [0x1061].
Comment 5 Bill Nottingham 1999-08-31 11:58:59 EDT
*** Bug 4794 has been marked as a duplicate of this bug. ***

Network install fails because of obsolete network card
driver.

Even the latest bootnet.img (May 28, 1999) uses obsolete
tulip.o module version 0.89H dated 5/23/98.  This old driver
cannot initialize newer cards based on the 21143 chipset
(e.g. Kingston KNE100TX).  Please update the bootnet.img to
include at least tulip.c:v0.91 (dated 4/14/99) or later.
Comment 6 Bill Nottingham 1999-08-31 12:45:59 EDT
*** Bug 3532 has been marked as a duplicate of this bug. ***

I am trying to use a Danpex 21143 NIC card with your Linux
6.0 and cannot get it to work.  This is a 100 meg FIBER
OPTIC card.  This card fails with both SC and ST
connectors.  I have tried both the TULIP and D21X4X drivers
without success.  We also have a TX(Copper Wire)model of
this card that I can get to work with the D21X4X driver,
not the TULIP driver though.

------- Additional Comments From jbj@redhat.com  06/17/99 14:16 -------
I'm changing the component to kernel because that's where driver
problems will be resolved ...

------- Additional Comments From piermattei@lancast.com  06/18/99 11:45 -------
Additional testing revealed that both the FIBER CARDS and TX(COPPER
WIRE)cards work with the TULIP driver under Linux 5.0.  Something is
different in 6.0 which causes the driver to no longer work.

------- Additional Comments From zab@redhat.com  07/14/99 10:45 -------
6.0 ships with the .89H version of the tulip driver.  There
is a newer version available directly from the author at
http://cesdis.gsfc.nasa.gov/linux/drivers/tulip.html
could you give that a try?
If that doesn't work, perhaps trying to force the media
with the tulip module's "options" parameter.  something like
insmod tulip options=8
would force full duplex fiber media, if the eeprom on the card lists
it as available.

sending the output of module insertion with 'debug=2' set should
give us some information that might be useful.BTW, the guy with the Winbond NE2000 thing should be using
ne2k-pci, not tulip.

Note You need to log in before you can comment on or make changes to this bug.