Bug 276851 - kickstart broke with %post
kickstart broke with %post
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 277451 278951 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 14:13 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 15:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart file (1.80 KB, text/plain)
2007-09-04 14:13 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2007-09-04 14:13:29 EDT
Description of problem:

Traceback:

  File "/usr/bin/anaconda" , line 916 in <module>
    kickstart.processKickstartFile(anaconda, opts.ksfile)
  File "/usr/lib/anaconda/kickstart.py", line 829, in processKickstartFile
    ksparser.readKickstart(file)
  File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 653, in
readKickstart
    self._stateMachine (lambda: fh.readline())
  File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 604, in
_stateMachine
    self.addScript()
  File "/usr/lib/anaconda/kickstart.py", line 750, in addScript
    self._script["chroot"], self._script["log"],
KeyError: 'chroot'

rawhide-20070904

kickstart attached.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2007-09-04 14:13:29 EDT
Created attachment 186391 [details]
kickstart file
Comment 2 Chris Lumens 2007-09-04 17:20:33 EDT
*** Bug 277451 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2007-09-05 14:02:02 EDT
*** Bug 278951 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.