Bug 277831 - virt-manager segfault while starting "connect process"
virt-manager segfault while starting "connect process"
Status: CLOSED DUPLICATE of bug 307531
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 277841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 02:38 EDT by Kyle Cronan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 22:55:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb stack trace (2.66 KB, text/plain)
2007-09-06 04:33 EDT, Kyle Cronan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 277471 None None None Never

  None (edit)
Description Kyle Cronan 2007-09-05 02:38:13 EDT
Description of problem:

Not sure if this could be a dup of 277471.  Since I updated to virt-manager 0.5,
if I start up a virtual machine, then try to open its console, virt-manager
exits suddenly.  Syslog indicates that "/usr/share/virt" segfaulted, whatever
that is (I don't think it's the python interpreter that's crashing!).  The
following are the last few lines of my ~root/.virt-manager/virt-manager.log file:

[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (manager:633) Clicked a VM row
[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (console:274) Trying console
login
[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (console:284) Graphics
console configured at vnc://<my_hostname>:5900
[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (console:297) Starting
connect process for <my_hostname> 5900


Version-Release number of selected component (if applicable):
virt-manager-0.5.0-1.fc8 for x86_64


Steps to Reproduce:
1. Open virt-manager
2. Double click on a VM
3. Click Run (VM starts running, but no console)
4. Close the console window
5. Double click on the VM again
  

Additional info:

Also, if I try to start the VM with the console window already open, the VM
starts running but the console window still says "not available" and no messages
appear in the log file (aside from the "VM started" message).  It's not until I
close this window and try to reopen it that I get a crash.

I considered that my problem could be changes to the way the config is created
in /etc/libvirt, but I have confirmed that the same error occurs with a newly
created VM (only difference was the table device anyway).
Comment 1 Kyle Cronan 2007-09-05 03:13:34 EDT
*** Bug 277841 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Berrange 2007-09-05 14:10:45 EDT
Yep, pretty likely to be a dup of bug 277471.

That said it works fine for me - so it must some difference in OS setup. Can you
try and capture a core dump for me.


install the XXXX-debuginfo RPMs for:

  virt-manager, libvirt, xen, python, pygtk2, gtk2, glib2 and glibc

And then set 'ulimit -c unlimited', run virt-manager and wait for it to crash.

Then obtain a stack trace from th core file using GDB:

  $ gdb /usr/bin/python core.XXXX
 (gdb) bt
   ....


Where core.XXXX is the corefile generated (it'll be in the current directory you
launched virt-manager from). Attach the stack trace to this bug.
Comment 3 Kyle Cronan 2007-09-06 04:33:57 EDT
Created attachment 188431 [details]
gdb stack trace
Comment 4 Daniel Berrange 2007-09-06 19:40:19 EDT
Thanks for the stack trace - it is crashing in quite possibly the worst &
hardest to debug bit of code there is :-)

I've rebuilt the GTK-VNC with some debug options enabled. Could you grab the
.1dantest RPMs from here, install them & try and crash again - you should see at
least some debug info stuffed on stdout

http://fedorapeople.org/~berrange/gtk-vnc/

If you could attach the complete set of debug messages it shows on the terminal
to this BZ, along with the complete /root/.virt-manager/virt-manager.log file it
would be very helpful.
Comment 5 Kyle Cronan 2007-09-09 18:19:52 EDT
Hmmm, are you sure those RPMs give debug info for you?  I may not have something
I need for that to work:

[kyle@jane ~]$ yum list gtk-vnc\*
Installed Packages
gtk-vnc.x86_64                           0.1.0-5.fc8.1dantest   installed
gtk-vnc-debuginfo.x86_64                 0.1.0-5.fc8.1dantest   installed
gtk-vnc-devel.x86_64                     0.1.0-5.fc8.1dantest   installed
gtk-vnc-python.x86_64                    0.1.0-5.fc8.1dantest   installed

[root@jane ~]# virt-manager
Segmentation fault

Nothing new in the virt-manager.log file either.
Comment 6 Daniel Berrange 2007-09-26 22:55:06 EDT
Turned out to be a GTK-VNC bug - fixed in rawhide.

*** This bug has been marked as a duplicate of 307531 ***

Note You need to log in before you can comment on or make changes to this bug.