Bug 277841 - virt-manager segfault while starting "connect process"
virt-manager segfault while starting "connect process"
Status: CLOSED DUPLICATE of bug 277831
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 02:44 EDT by Kyle Cronan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 03:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 277471 None None None Never

  None (edit)
Description Kyle Cronan 2007-09-05 02:44:13 EDT
Description of problem:

Not sure if this could be a dup of 277471.  Since I updated to virt-manager 0.5,
if I start up a virtual machine, then try to open its console, virt-manager
exits suddenly.  Syslog indicates that "/usr/share/virt" segfaulted, whatever
that is (I don't think it's the python interpreter that's crashing!).  The
following are the last few lines of my ~root/.virt-manager/virt-manager.log file:

[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (manager:633) Clicked a VM row
[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (console:274) Trying console
login
[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (console:284) Graphics
console configured at vnc://<my_hostname>:5900
[Tue, 04 Sep 2007 23:08:14 virt-manager 4877] DEBUG (console:297) Starting
connect process for <my_hostname> 5900


Version-Release number of selected component (if applicable):
virt-manager-0.5.0-1.fc8 for x86_64


Steps to Reproduce:
1. Open virt-manager
2. Double click on a VM
3. Click Run (VM starts running, but no console)
4. Close the console window
5. Double click on the VM again
  

Additional info:

Also, if I try to start the VM with the console window already open, the VM
starts running but the console window still says "not available" and no messages
appear in the log file (aside from the "VM started" message).  It's not until I
close this window and try to reopen it that I get a crash.

I considered that my problem could be changes to the way the config is created
in /etc/libvirt, but I have confirmed that the same error occurs with a newly
created VM (only difference was the table device anyway).
Comment 1 Kyle Cronan 2007-09-05 03:10:24 EDT
My apologies for the duplicate report -- I was getting some kind of proxy error
from the Bugzilla server and I didn't think it was actually getting posted.

*** This bug has been marked as a duplicate of 277831 ***

Note You need to log in before you can comment on or make changes to this bug.