Bug 283561 - "yum clean" downloads package metadata
Summary: "yum clean" downloads package metadata
Status: CLOSED DUPLICATE of bug 276151
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-08 13:20 UTC by Mamoru TASAKA
Modified: 2014-01-21 22:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-08 13:53:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2007-09-08 13:20:56 UTC
Description of problem:
For example, when I try "yum clean all", first yum 
downloads package metadata from repositories, then
removes the metadata which yum just downloaded.

This behavior is apparently redundant.

Version-Release number of selected component (if applicable):
yum-3.2.4-4.fc8

How reproducible:
100%

Steps to Reproduce:
1. yum clean all
  
Actual results:
[root@localhost ~]# yum clean all
livna-devel               100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 105 kB    00:00     
livna-devel-DEBUG         100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================|  36 kB    00:00     
koji                      100% |=========================| 1.1 kB    00:00     
primary.xml.gz            100% |=========================| 2.9 MB    00:03     
<some lines omitted>
core-devel-domes-CACHE    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 5.1 MB    00:03     
Cleaning up Everything

Expected results:
"yum clean all" just cleans up metadata, packages and so on

Additional info:
In my memory yum 3.2.1 (maybe also 3.2.2) just cleans up metadata.
For 3.2.3, I forgot how to behave for this.

Comment 1 Seth Vidal 2007-09-08 13:53:44 UTC

*** This bug has been marked as a duplicate of 276151 ***


Note You need to log in before you can comment on or make changes to this bug.