Bug 276151 - yum downloads metadata unnecessarily
Summary: yum downloads metadata unnecessarily
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 283561 284381 (view as bug list)
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-09-04 13:46 UTC by Craig Schlenter
Modified: 2014-01-21 22:59 UTC (History)
5 users (show)

Fixed In Version: 3.2.5-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 03:20:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Craig Schlenter 2007-09-04 13:46:33 UTC
Yum is downloading metadata when it shouldn't have to - surely it can't
need metadata when I am asking it to clean everything? Yum version is 3.2.4
btw.

root@linux~]# yum clean all
Loading "changelog" plugin
development               100% |=========================| 2.1 kB    00:08     
primary.sqlite.bz2        100% |=========================| 5.1 MB    05:12     
Cleaning up Everything

Thanks!

Comment 1 Seth Vidal 2007-09-04 19:50:32 UTC
Thanks - found the bug - fixed in upstream will be out in 3.2.5 and later.
patch which fixes it is here:
http://devel.linux.duke.edu/gitweb/?p=yum.git;a=commitdiff;h=623233e928ae79040a4c75f6eb7548ce7cd56cbb


Comment 2 Seth Vidal 2007-09-08 13:53:45 UTC
*** Bug 283561 has been marked as a duplicate of this bug. ***

Comment 3 Seth Vidal 2007-09-10 13:03:49 UTC
*** Bug 284381 has been marked as a duplicate of this bug. ***

Comment 4 Jan ONDREJ 2007-09-10 13:19:50 UTC
My bug writes also something about a filtering these unnecessary downloads for
yum update or yum install:

May be yum can detect this after downloading 2-3 files and re-download
repomd.xml from same server as primary.sqlite file.
Is it possible to implement something like this?


Comment 5 Seth Vidal 2007-09-10 13:49:00 UTC
install/update downloads of metadata is another thing that is hard to address
right now.

If you're talking about a stale repomd.xml file then some of that is supposed to
be handled by mirrormanager.


Comment 6 Fedora Update System 2007-09-12 16:41:16 UTC
yum-3.2.5-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-09-18 03:20:46 UTC
yum-3.2.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.