Bug 284381 - Yum is downloading primary.sqlite even on "yum clean".
Yum is downloading primary.sqlite even on "yum clean".
Status: CLOSED DUPLICATE of bug 276151
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 05:26 EDT by Jan ONDREJ
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 09:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2007-09-10 05:26:08 EDT
Description of problem:
Yum is repeatedly downloading primary.sqlite.bz2 when old repomd.xml downloaded
from a mirror. This happens on "yum clean" command too. I am unable to clean
metadata with yum commands, only with:
  rm -rf /var/cache/yum/*
command.

Version-Release number of selected component (if applicable):
yum-3.2.4-2.fc7

How reproducible: sometimes, when wrong mirror selected


Steps to Reproduce:
1. try to update from old or very new mirror. May be you can simulate this by
touching /var/cache/yum/fedora/repomd.xml file.
2. yum update
3. yum clean
  
Actual results:
Yum is searching for primary.sqlite file corresponding to it's repomd.xml (or
other file?)

[root@hnedy ~]# yum clean all
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:06
ftp://fedora.bu.edu/releases/7/Everything/i386/os/repodata/primary.sqlite.bz2: [
Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:14
http://ftp.kddilabs.jp/Linux/packages/fedora/releases/7/Everything/i386/os/repod
ata/primary.sqlite.bz2: [Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:00
http://ftp.upjs.sk/pub/fedora/linux/releases/7/Everything/i386/os/repodata/prima
ry.sqlite.bz2: [Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:08
http://ftp.usf.edu/pub/fedora/linux/releases/7/Everything/i386/os/repodata/prima
...

Expected results:
Yum data cleanup.

Additional info:
Same problem for "yum clean metadata".
This command downloads more unnecessary data from mirrors, generating high
mirror loads on client and server side. May be yum can detect this after
downloading 2-3 files and re-download repomd.xml from same server. I think "yum
clean all" with no network access is recommended.
Comment 1 Seth Vidal 2007-09-10 09:03:48 EDT

*** This bug has been marked as a duplicate of 276151 ***

Note You need to log in before you can comment on or make changes to this bug.