Bug 296841 - [enh] IrDA networking support
[enh] IrDA networking support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
: 362201 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 15:32 EDT by Daniel Qarras
Modified: 2015-09-17 03:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 11:19:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2007-09-19 15:32:49 EDT
In the spirit of Bug 136663:

NetworkManager doesn't support infrared networking. Connections over IrDA using
PPP are very useful with mobile phones and/or laptops which do not support
Bluetooth. Adding IrDA support would greatly simplify networking using IrDA.
Comment 1 Daniel Qarras 2007-09-19 15:46:52 EDT
FWIW, a related bug about GPRS networking is Bug 296851.
Comment 2 Daniel Qarras 2007-12-06 11:01:51 EST
Another related report is Bug 362201 about IrDA connection parameters.
Comment 3 Daniel Qarras 2008-02-16 10:01:09 EST
I'll add also that Bug 263881 was about setting correct device in
/etc/sysconfig/irda. If NM is to support IrDA it would be cool to also have an
option to probe/detect/select correct IrDA device.
Comment 4 Daniel Qarras 2008-02-22 12:11:13 EST
For completeness I'll document below what I need for a GPRS connection over IrDA
with my Nokia mobile phone. Probably well-known facts but anyway:

0) IrDA device configuration needs to be complete before doing anything else.
Device specific and not directly related to NM. For my hardware these two lines
in /etc/modprobe.conf are needed:

alias irda0 nsc-ircc
install nsc-ircc /bin/setserial /dev/ttyS1 uart none; /sbin/modprobe
--ignore-install nsc-ircc

1) /etc/sysconfig/irda needs to have:

IRDA=yes
DEVICE=irda0
DISCOVERY=yes

Those are passed to irattach when starting the irda service.

2) After starting the irda service the IrDA connection parameters must be
adjusted for numerous phone models (including mine, obviously):

# Adjust IrDA settings for GPRS
echo 115200 > /proc/sys/net/irda/max_baud_rate
echo 2000 > /proc/sys/net/irda/max_tx_data_size
echo 1000 > /proc/sys/net/irda/min_tx_turn_time
echo 1 > /proc/sys/net/irda/max_tx_window

3) I'm using wvdial with following config as /etc/wvdial.conf:

[Dialer Defaults]
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = ATM0
SetVolume = 0
Dial Command = ATDT

[Dialer gprs]
Modem = /dev/ircomm0
#Init4 = AT+CGDCONT=,,”airtelgprs.com”
ISDN = 0
Modem Type = Analog Modem
Phone = *99#
Username = A
Password = B
Stupid Mode = 1

Username and password can be anything. In some cases (probably operator
specific) one needs the Init4 parameter to get DNS servers but for me this works
ok without it.

4) Then just "wvdial gprs" and I'm connected.

So the point here is that I hope some day at least part of this could be done
with NetworkManager.

Thanks.
Comment 5 Daniel Qarras 2008-03-04 16:30:12 EST
The wvdial.conf above is not optimal. This one is much better:

[Dialer Defaults]
Baud = 115200
Init1 = ATZ E0
Dial Command = ATDT

[Dialer gprs]
Modem = /dev/ircomm0
Phone = *99#
Username = A
Password = B
Comment 6 Bug Zapper 2008-05-13 23:15:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 John Poelstra 2008-10-10 18:12:34 EDT
This bug has been triaged
Comment 8 Daniel Qarras 2009-12-04 14:41:07 EST
This report was about NM IrDA support.. I wonder is it worth the effort nowadays anymore as more and more phone are lacking IrDA and come with Bluetooth instead or shall we keep this still open?

Thanks.
Comment 9 Dan Williams 2009-12-04 15:08:45 EST
GsmArena lists 363 phones that have IR ports but do not have Bluetooth.  However, only 17 of those phones have at least EDGE.  However, some devices that have IR but no BT were released as recently as 2007 (http://www.gsmarena.com/sony_ericsson_k220-1841.php).  In the end, NM IR support probably won't get done unless somebody shows up with patches.

ModemManager should support the device fine when it shows up and is connected, but if the IR stack doesn't support hotplug or sysfs correctly then we might have a problem.  We'd probably need to do the same thing with IR as we do with Bluetooth since you can't really scan for the device.  Which means that once a connection was created for the device (do IR devices have some sort of MAC or other unique ID at all?) it would always be shown in the menu no matter whether the device was on or off.  When you choose the phone from the menu, NM would try to connect, and if the device was off the connection would simply fail.

I'll take patches, but note that patches would probably need to be based on what will become NM 0.8.1 which has a bunch of fixes that enable Bluetooth DUN, which would also be quite useful to IrDA.
Comment 10 Dan Williams 2010-02-08 20:26:22 EST
If anyone still has an IrDA capable phone, does ModemManager find the device if it's running when you start the IrDA connection?
Comment 11 Daniel Qarras 2010-02-09 12:35:02 EST
I have a Nokia 6021 to test with. When I start IrDA with:

# irattach irda0

I can then run gnokii --identify successfully with this /etc/gnokiirc:

[global]
port = /dev/ircomm0
model = AT
connection = serial

However, I don't see any messages from ModemManager in the syslog and test/mm-test.py reports "No modems found".

Please let me know if there were anything else I could test? Thanks.
Comment 12 Dmitry Butskoy 2011-07-15 12:50:33 EDT
*** Bug 362201 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2014-01-14 11:19:27 EST
THis is quite unlikely to happen unless community patches come in, and hardware that supports IrDA is pretty much no longer available...

Note You need to log in before you can comment on or make changes to this bug.