Bug 298171 - Allows autofs to do automount lookups via nscd through LDAP
Allows autofs to do automount lookups via nscd through LDAP
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Ian Kent
Brock Organ
PMCmmt
: FutureFeature
: 306571 (view as bug list)
Depends On: 230430
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 10:27 EDT by Ian Kent
Modified: 2008-05-21 10:37 EDT (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to initialize sasl callbacks unconditionally on autofs LDAP library load (4.04 KB, patch)
2008-04-02 11:34 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Comment 1 Ben Levenson 2007-11-15 11:22:23 EST
*** Bug 306571 has been marked as a duplicate of this bug. ***
Comment 3 Ian Kent 2008-01-08 04:08:28 EST
I've done about as much as I can on this now.
We need some customer testing.
Comment 6 Ian Kent 2008-04-02 11:34:07 EDT
Created attachment 300078 [details]
Patch to initialize sasl callbacks unconditionally on autofs LDAP library load
Comment 7 Ian Kent 2008-04-02 11:40:17 EDT
Setting bug back to assigned and blocker=?.

An issue with the change for this bug has been reported
upstream and in Fedora bug 438120. The upstream reporter
tested the patch above and verified that it fixed the
problem. Unfortunately, the reporter of 438120 has not
responded but I believe I understand the source of the
problem.

When the autofs LDAP lookup shared library is dlopened
and subsequently dlclosed the library may not actually be
unloaded prior to the next dlopen. If it also happens that
the dependent SASL library is unloaded between this dlcose
and the following dlopen the sasl library callback functions
are not initialized since the autofs LDAP lookup library thinks
this has already been done (the library data segment still
exists).

If the situation above happens a SEGV occurs when the SASL
library tries to use the callback functions.

Part of the changes made for the implementation of this bug
require that autofs be sensitive to configuration changes and
consequently the autofs LDAP lookup library can be closed and
re-opened as part of this process which leads to the situation
described above.

Ian
Comment 9 Ian Kent 2008-04-08 09:37:37 EDT
Correction committed and package built.
Comment 13 errata-xmlrpc 2008-05-21 10:37:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.