Bug 298691 - applet doesn't appear on login
applet doesn't appear on login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
: 299491 301611 (view as bug list)
Depends On:
Blocks: F8Blocker F8Test3
  Show dependency treegraph
 
Reported: 2007-09-20 13:50 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 18:36:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch that might help (884 bytes, patch)
2007-09-22 21:24 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Jeremy Katz 2007-09-20 13:50:08 EDT
The applet doesn't want to appear in the notification area when I login. 
Killing it and restarting it works fine.  Nothing obvious in ~/.xsession-errors.
 And the process is running.
Comment 1 Matthias Clasen 2007-09-21 22:51:21 EDT
*** Bug 299491 has been marked as a duplicate of this bug. ***
Comment 2 Tom London 2007-09-22 15:19:27 EDT
killing and restarting nm-applet from a text window makes it appear.

Wireless networks are only seen if SELinux is in permissive mode.

I forwarded the details to fedora-selinux:
https://www.redhat.com/archives/fedora-selinux-list/2007-September/msg00082.html
Comment 3 Matthias Clasen 2007-09-22 21:24:51 EDT
Created attachment 203291 [details]
a patch that might help

Here is a patch I sent to dcbw, which might help with the incorrect setup of
the icon at start.
Comment 4 Matthias Clasen 2007-09-22 21:27:44 EDT
*** Bug 301611 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Clasen 2007-09-24 18:36:14 EDT
Patch has been committed upstream and will appear in the next snapshot in
rawhide later tonight.
Comment 6 Tom London 2007-09-25 12:23:28 EDT
I installed NetworkManager-0.7.0-0.3.svn2880.fc8 and newest SELinux policy and
rebooted.

After gdm login, nm-applet now appears (yea!), but the icon has the little 'red
X' indicating no network connection.

But my wired network is up. 

'Left clicking' on the icon shows the Wired network selected and active, and
shows all my wireless networks.

Selecting 'Wired Network' forces a disconnect/reconnect, with the proper icon
now displayed.

Note You need to log in before you can comment on or make changes to this bug.