Bug 303951 - When trying "Test sound settings" with PulseAudio running, ekiga gets SIGABRT
When trying "Test sound settings" with PulseAudio running, ekiga gets SIGABRT
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 369631 376761 (view as bug list)
Depends On: 432790
Blocks: 369631
  Show dependency treegraph
 
Reported: 2007-09-24 16:24 EDT by Matěj Cepl
Modified: 2008-03-30 13:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 05:29:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from gdb (15.86 KB, text/plain)
2007-09-24 16:24 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2007-09-24 16:24:14 EDT
Description of problem:
When trying to run ekiga with PulseAudio (and alsa-plugins-pulseaudio) I am not
able to run "Test sound settings" (or something, using Czech localized version,
which says "Otestovat nastavení"), ekiga crashes in 100% cases. Attaching backtrace.

Version-Release number of selected component (if applicable):
[matej@viklef ~]$ rpm -qa ekiga\* pwlib\* opal\* \*alsa\* | sort
alsa-lib-devel-1.0.14-3.fc7
alsa-lib-1.0.14-3.fc7
alsa-plugins-debuginfo-1.0.14-2.fc7
alsa-plugins-pulseaudio-1.0.14-2.fc7
alsa-utils-1.0.14-1.fc7
ekiga-debuginfo-2.0.11-1.fc7
ekiga-2.0.11-1.fc7
opal-debuginfo-2.2.11-1.fc7
opal-2.2.11-1.fc7
pwlib-debuginfo-1.10.10-1.fc7
pwlib-1.10.10-1.fc7
[matej@viklef ~]$ 


How reproducible:
100%

Steps to Reproduce:
1.run ekiga (with PA up and running and playing Jethro Tull's Aqualung)
2.walk through "First time running" wizard
3.When you get to audio settings (with both scrolldown boxes let in "Default")
click on "Test settings" button.
  
Actual results:
crash -- bug-buddy was not able to collect it, but when running in gdb I got it.

Expected results:
beautiful sound -- best would be Ian Anderson with flute :-)

Additional info:
Comment 1 Matěj Cepl 2007-09-24 16:24:14 EDT
Created attachment 204541 [details]
backtrace from gdb
Comment 2 Konrad Karl 2007-11-04 18:20:36 EST
It crashes on Rawhide too. For conversation I am using an USB headset which 
works OK.

However in Preferences -> Sound events:
chosing the default sound channel and playing e.g. the ring sound produces:

ekiga: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Aborted

I discovered this while wondering why ekiga silently disappeared when there
was an incoming call.
Comment 3 Jan "Yenya" Kasprzak 2007-12-04 10:05:06 EST
As I have written to ekiga-list some time ago, this is probably an ALSA bug.
Related bug reports are

http://www.pulseaudio.org/ticket/23 and
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601
Comment 4 Matěj Cepl 2008-01-02 05:22:03 EST
It seems to me that with the later Rawhide it gets better. Reporter and Yenya,
can you reproduce it still with the latest Rawhide?
Comment 5 Jan "Yenya" Kasprzak 2008-01-02 09:18:27 EST
I don't want migrate my primary workstation to rawhide. I am however willing to
upgrade (or rebuild) selected packages from rawhide. Which packages and which
versions should I upgrade?

In the meantime, I have written a simple D-Bus hack which suspends pulseaudio
when the call begins, so having ekiga access the raw device works:

http://www.fi.muni.cz/~kas/blog/index.cgi/computers/desktops/ekiga-pulseaudio-dbus.html
Comment 6 Matěj Cepl 2008-01-02 10:52:26 EST
Yenya, sorry, I overlooked that you are on F7. No, there is probably no good way
how to recompile PA on F7 without upgrading it to be almost Rawhide. Is it
correct, Lennart?
Comment 7 Jan "Yenya" Kasprzak 2008-01-02 11:14:13 EST
No, I use F8 now. The problem still exists on F8, so you can update this bug to
F8 (I don't have the rights to do it).

Also, if the reports from the comment #3 suggest it is an ALSA bug, it would
probably be ALSA rather than PA which I should recompile.
Comment 8 Matěj Cepl 2008-01-02 17:00:36 EST
Of course, you right -- changing components.

Martin, this is IMHO the upstream ALSA bug from comment 3, and although I would
get it all the time on F8, it evaporated just before the Xmass on Rawhide.
Comment 9 James Gregory 2008-01-11 10:42:38 EST
I've just commented on the ALSA bug tracker as I am experiencing the same issue
with Ekiga under Fedora 8. Considering there haven't been any posts on that bug
since the end of November, I wouldn't hold my breath that it is going to be
fixed any time soon...
Comment 10 Jan "Yenya" Kasprzak 2008-01-11 11:58:33 EST
As for comment #8 - Matej, could you try to pinpoint which package has caused
the problem to go away? I have looked at rawhide, and the last alsa-lib is

alsa-lib-1.0.15-1.fc9.src.rpm

while on F8 there are the following:

alsa-lib-1.0.15-1.fc8.x86_64
alsa-lib-1.0.15-1.fc8.i386

which are probably only rebuilds of the same SRPM. So I doubt rawhide has any
significant change to alsa-lib against F8.
Comment 11 Matěj Cepl 2008-01-11 13:22:52 EST
Well, I said better -- and really ekiga doesn't crash on me (packages
ekiga-2.0.11-2.fc9.x86_64, opal-2.2.11-2.fc9.x86_64, and
pwlib-1.10.10-4.fc9.x86_64), but it is not to say that it works flawlessly. DMTF
doesn't work at all, so I still have to use linphone.
Comment 12 Matěj Cepl 2008-01-11 13:23:34 EST
... and is that ALSA bug in alsalibs, or in the kernel part of ALSA?
Comment 13 Angel Marin 2008-01-28 16:12:24 EST
This no longer happens here with the last set of f8 updates:
kernel-2.6.23.14-107.fc8.x86_64, pulseaudio-*-0.9.8-5.fc8.x86_64 and
alsa-plugins-pulseaudio-1.0.15-2.fc8.x86_64
Comment 14 Konrad Karl 2008-01-29 16:38:24 EST
No such luck on i[36]86:

ekiga-2.0.11-1.fc8
pulseaudio-0.9.8-5.fc8
kernel-2.6.23.14-107.fc8
alsa-plugins-pulseaudio-1.0.15-2.fc8

ekiga: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Aborted

whenever I select the default sound device as Alternative Output Device.


Comment 15 James Gregory 2008-02-07 09:41:33 EST
alsa 1.0.16 was released yesterday and may fix the problem. Would it be possible
to get alsa updated?
Comment 16 Martin Stransky 2008-02-08 08:39:15 EST
is alsa-drivers already in kernel?
Comment 17 Ignacio Vazquez-Abrams 2008-02-15 21:37:33 EST
*** Bug 376761 has been marked as a duplicate of this bug. ***
Comment 18 Ignacio Vazquez-Abrams 2008-02-15 21:38:47 EST
*** Bug 369631 has been marked as a duplicate of this bug. ***
Comment 19 Martin Stransky 2008-02-22 05:29:44 EST
alsa-libs-1.0.16 is in rawhide now.
Comment 20 Konrad Karl 2008-03-28 11:12:31 EDT
Tried on full uptodate F8, alsa-plugins-1.0.15-3.fc8.1.src.rpm - ekiga is
still not stable.

I set the sound events to "default", pressed Test and was able one time 
to hear exactly one ring sound, afterwards ekiga died with this famous 
assertion.

On the next tries I was not able to hear anything because of instant crash.
In those cases ekiga had the tendency to consume 100% CPU.

For conversation I am using a USB headset.

Will try to investigate over the weekend and provide more exact description
which assert it actually triggered (I am in the office now).

Can anybody confirm that it works in F9 beta? (read rumors about this)

Konrad

Note You need to log in before you can comment on or make changes to this bug.