Bug 30696 - [usb] Installer hangs unmounting /proc/bus/usb after upgrade finishes
[usb] Installer hangs unmounting /proc/bus/usb after upgrade finishes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
: 32237 35826 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 16:09 EST by Joachim Kunze
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-25 04:57:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Kunze 2001-03-05 16:09:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-0.1.19 i686; en-US; 0.8)
Gecko/20010217


every upgrade I performed fisher->wolverine->rc2 my system hangs after
updating in graphic mode when the procfs will be unmouted. 
I use a USB mouse (detected correctly) and when I get the message
'unmounting /proc/bus/usb' the system hangs and after the reboot a fsck
will be perfomed 

Reproducible: Always
Steps to Reproduce:
1. update an older system (graphic mode) and usb mouse
2. finish the update process
3. system hangs during reboot
4. last message 'unmounting /proc/bus/usb'
5. fsck is performed after reboot 
	

Expected Results:  reboot without hanging system
Comment 1 Michael Fulbright 2001-03-05 17:36:26 EST
I have not been able to reproduce this on my hw.

What is your hardware configuration?
Comment 2 Joachim Kunze 2001-03-06 03:41:47 EST
Motherboard ASUS CUSL2-C
Proc. Intel Celeron 700 Mhz
Logitech Wheelmouse USB
256 MB RAM
Adaptec 2940 UW
Graphiccontr. Riva TNT2 Vanta
ISDN Fritz Card PCI
3COM 905 TX

What else do you need
Comment 3 Joachim Kunze 2001-03-06 04:12:25 EST
Motherboard ASUS CUSL2-C
Proc. Intel Celeron 700 Mhz
Logitech Wheelmouse USB
256 MB RAM
Adaptec 2940 UW
Graphiccontr. Riva TNT2 Vanta
ISDN Fritz Card PCI
3COM 905 TX

What else do you need
Comment 4 Glen Foster 2001-03-06 15:43:59 EST
Aaron, can you help look at (and possibly reproduce) this on your ASUS board?
Comment 5 Glen Foster 2001-03-06 16:14:19 EST
We (Red Hat) should really try to fix this before next release.
Comment 6 Joachim Kunze 2001-03-07 04:05:08 EST
I'd like to emphasize, that the system works pretty well after the update with
my USB-mouse. The issue is only the update-process itself.

I upgraded yesterday another system (Dell) with an USB-mouse with the same result.
The systems hangs in the shutdown-process directly after the update, performs a
fsck and work form then on without a problem.
Comment 7 Michael Fulbright 2001-03-07 18:30:04 EST
Waiting on a system that exhibits this behavior to investigate further.
Comment 8 Michael Fulbright 2001-03-09 14:55:23 EST
What is the Dell model #?
Comment 9 Joachim Kunze 2001-03-11 07:01:39 EST
I upgraded a Dell Latitude LSt Celeron 400 and the system hung at the same point
after the graphical upgrade has finished.
Comment 10 Michael Fulbright 2001-03-13 12:22:06 EST
Brent please see if we have similar hardware available and verify.
Comment 11 Bill Nottingham 2001-03-14 11:46:01 EST
See bug #30304.
Comment 12 Brent Fox 2001-03-14 12:02:58 EST
I wasn't able to reproduce bug #30304 because the machine that exhibited the
behavior for Brock died before I could test it.  I haven't seen this behavior on
any of the machines that I've tried with usb devices.
Comment 13 Brent Fox 2001-03-14 15:03:04 EST
We don't have an exact match for this hardware.  In my test machine, I have an
ASUS P28-F motherboard with a Celeron 333MHz in it, and that's the closest match
we have.  None of the machines I've done installs on with USB mice demonstrate
this problem.  I'm thinking that the problem is between the bios and the kernel
somewhere.  The installer is trying to unmount /proc/bus/usb, but the kernel (or
something) won't let go.  However, this seems to work fine on all the machines
here....  Reassigning to the kernel.
Comment 14 Joachim Kunze 2001-03-15 08:39:03 EST
I my opinion the ASUS P28-F motherboard is not very close to my ASUS CUSL2-C,
because my board is based on the socket370 / Intel 815 EP chipset and your
testboard is based on slot1 / Intel 440 BX chipset.
Comment 15 Arjan van de Ven 2001-03-19 12:56:40 EST
*** Bug 32237 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2001-03-20 15:42:49 EST
Just a note - the machine in question in bug 30304 is working and has shown the
lockup using the qa0319.2 tree.
Comment 17 Alan Cox 2001-03-21 07:58:20 EST
At the point it hangs does capslock work, does switching virtual consoles work ?
Comment 18 Joachim Kunze 2001-03-21 14:58:41 EST
I was not able to switch to another console when the system hangs. I haven't
checked capslock - is this of importance?
Comment 19 Pete Zaitcev 2001-03-21 23:59:05 EST
If Magic Sysrq (Alt-Ctrl-Space), or right_Alt-ScrLock
may provide some information if they work and if
the kernel was compiled with "call trace" enabled.

If only we knew where "mount" hangs.
So far I see only one suspicious place, that is
usb_devfs_put_super=>iput=>clear_inode=>wait_on_inode.
Comment 20 Pete Zaitcev 2001-03-22 20:39:14 EST
Oh, I could have spared the effort. Here's a mail from Bill:

---------------------------
Date: Mon, 19 Mar 2001 15:34:29 -0500
From: Bill N. <...>
Subject: hang on unmount of /proc/bus/usb

We're having problems with the unmounting of /proc/bus/usb
on *some* hardware in the install environment.

The call trace from alt-sysrq-p shows it in the unmount
process, with a call trace:
    iput
    <stuff in modules>
    kill_super
    read_super

I really need to look at the stuff that's in modules, but
it looks like something in usbdevfs is broken.

Bill
---------------------------

So, it's in iput, but not in wait_on_inode? Hmmm....
Comment 21 Matthias Grimm 2001-03-25 01:24:44 EST
Hi,
I got the same problem here, when INSTALLING wolverine on my box, it hangs on 
dismounting /proc/bus/usb.

Hardware:
ASUS A7V-133, 384MEG, Razer 2000 USB-Mouse, Two IBM DTLA 307075 as raid0 on 
internal Promise IDE-controller, one IBM DRVS09V, one Plextor PX40TS, one Teac 
CD-R58S hooked to an Adaptec AHA 2940U2W with latest BIOS. Wolverine is 
installed on the scsi-hdd.
Comment 22 Pete Zaitcev 2001-06-25 16:25:11 EDT
*** Bug 35826 has been marked as a duplicate of this bug. ***
Comment 23 Pete Zaitcev 2001-09-20 14:38:34 EDT
Did this ever happen in a 7.2 beta or release?
Comment 24 Joachim Kunze 2001-09-25 04:57:44 EDT
No, on 7.2 Beta it works fine...
So the bug seems to be fixed.
Comment 25 Pete Zaitcev 2001-09-25 12:20:33 EDT
Honestly, I did not hack anything in usb-storage, but only
tracked what they (Matt Dharm in particular) did on linux-usb-devel.
I did not hear any single report of in in 7.2 either.

Note You need to log in before you can comment on or make changes to this bug.