Bug 316581 - [hts-5.1.1][x86_64][video][RHEL5.1] - Video FAILED xstatus command
[hts-5.1.1][x86_64][video][RHEL5.1] - Video FAILED xstatus command
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
: Documentation
: 316591 318151 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 06:01 EDT by Satyabrata Maitra
Modified: 2009-08-27 12:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ====== VIDEO test fails. Consequence: ============ If there's no displays connected to the system, the VIDEO test will fail with a strange error message. Fix: ==== Add the checking for connected displays. Result: ======= If there's no connected displays, the VIDEO test will report the correct error message.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 12:34:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
video-all-required-files (440.00 KB, application/x-tar)
2007-10-03 06:01 EDT, Satyabrata Maitra
no flags Details
video.py patch to check for connected displays (1.79 KB, patch)
2009-06-12 12:00 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Satyabrata Maitra 2007-10-03 06:01:31 EDT
Description of problem:
Video Testing for x86_64 arch on RHEL5.1 Server is FAIL. Its showing some Error
in output.log which is paste below as well as attached with this bug.
Error :
FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.

FAILED xstatus command
Video test on device video-card FAILED
...finished running ./video.py, exit code=1

Version-Release number of selected component (if applicable):
hts-5.1.1
tree followed : 20070927.0

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
FAIL

Expected results:
Should be PASS

Additional info:
Comment 1 Satyabrata Maitra 2007-10-03 06:01:31 EDT
Created attachment 214431 [details]
video-all-required-files
Comment 2 Greg Nichols 2007-10-05 14:11:24 EDT
*** Bug 318151 has been marked as a duplicate of this bug. ***
Comment 3 Greg Nichols 2008-03-06 10:35:13 EST
*** Bug 316591 has been marked as a duplicate of this bug. ***
Comment 4 Greg Nichols 2008-09-12 12:17:25 EDT
We need to look at adding xrandr or perhaps HAL, to verify that a display is attached.
Comment 6 Rob Landry 2009-05-12 14:46:29 EDT
We should probably add the xrandr is there anything attached thing
and then close this out, or do we have a reliable reproducer we could know it's fixed on?
Comment 7 Rob Landry 2009-06-10 14:35:36 EDT
To add context, if all of the outputs are disconnected we should just fail?  In the following example output the attached laptop panel is attached.


 xrandr
Screen 0: minimum 320 x 200, current 1360 x 768, maximum 2384 x 768
VGA-0 disconnected 1360x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+   60.0  
   800x600        60.3  
   640x480        59.9  
S-video disconnected (normal left inverted right x axis y axis)
  1360x768_60.00 (0x50)   84.8MHz
        h: width  1360 start 1432 end 1568 total 1776 skew    0 clock   47.7KHz
        v: height  768 start  771 end  781 total  798           clock   59.8Hz
Comment 8 Greg Nichols 2009-06-12 12:00:56 EDT
Created attachment 347600 [details]
video.py patch to check for connected displays
Comment 12 Yan Tian 2009-08-13 04:39:00 EDT
Verified v7-1.0-14.el5 video test passed on RHEL5.4 Server x86_64 system.
Comment 14 YangKun 2009-08-20 22:51:01 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Cause:
======
VIDEO test fails.

Consequence:
============
If there's no displays connected to the system, the VIDEO test will fail with a strange error message.

Fix:
====
Add the checking for connected displays.

Result:
=======
If there's no connected displays, the VIDEO test will report the correct error message.
Comment 15 errata-xmlrpc 2009-08-27 12:34:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1234.html

Note You need to log in before you can comment on or make changes to this bug.