Bug 31879 - (Savage) StarOffice or OpenOffice freezes machine
(Savage) StarOffice or OpenOffice freezes machine
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 32399 55619 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-15 11:55 EST by Martin Høy
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 20:10:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Høy 2001-03-15 11:55:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686)




Reproducible: Always
Steps to Reproduce:
1.Use XFree-4.0.2 from wolverine (on a RH7.0 laptop)
2.Run soffice
	

Actual Results:  When I start StarOffice (5.2), the machine first becomes
slow (e.g. very slow response on mouse) and then freezes completely after
about 30 seconds.

Expected Results:  When I use the XFree-3.3.6-driver from S3 (by changing
the X softlink), StarOffice works fine.

I'm running RedHat Linux 7.0 on a laptop with S3 Savage/MX. Since this card
is supported in XFree86-4.0.2, I installed the X-rpms (plus the rpms that X
required) from wolverine. I haven't tried to reproduce this with a full
wolverine installation.
Comment 1 Mike A. Harris 2001-03-15 16:34:54 EST
Upgrade to the latest rawhide version of XFree, Mesa and the kernel.
The savage driver was recently updated.  I do not have StarOffice to
test this with, but if the latest RPM's do not work for you, I will get
someone in the Durham office to try and reproduce the problem.

Does the new stuff fix it for you?
Comment 2 Martin Høy 2001-03-16 03:37:32 EST
I have tried with XFree86-4.0.2-12.1 and Mesa-3.4-10 from rawhide + kernel
2.4.3-pre4; the problem is the same. So whatever the problem is, it also applies
to the latest rawhide rpms.

The notebook is an ASUS L8400-C, and lspci reports the S3 card as:
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/MX-/IX (rev 11)

XFree-4.0.2 reports the card as:
(--) PCI:*(1:0:0) S3 Savage/MX-MV rev 17, Mem @ 0xf0000000/27

We have reproduced the problem with a collegue that has a similar notebook (same
S3-card).
Comment 3 Martin Høy 2001-03-22 11:25:15 EST
From the homepage of the savage driver, http://www.probo.com/timr/savage40.html,
I found that this is a known bug.

StarOffice has a work-around; setting SAL_DO_NOT_USE_INVERT50=true "fixes" the
problem. I don't know who's to blame, StarOffice or the savage driver.
Comment 4 Mike A. Harris 2001-03-22 16:06:19 EST
As far as I'm concerned - *NO* software should ever hang the machine.  If
it does, whatever is arbitrating access to hardware is responsible for
ensuring the stability and proper operation of that hardware.

So, if Staroffice hangs the machine, it is an XFree86 bug hands down as
it should be impossible for an application to do so.  The only exception
to this rule IMHO is a fatal hardware flaw, which some hardware has I believe.
Nonetheless this issue will likely have to be addressed in a driver update.

Thanks for looking into this and providing more details, info.  I'll see what
I can come up with.
Comment 5 Mike A. Harris 2001-03-28 01:17:50 EST
XFree86 4.0.3-4 contains the updated Savage driver version 1.15 from
the above URL.  Please try it when it is available, with the environment
variable fix above. Realistically, the driver author will have to fix
this one, and he's aware of the problem but not of a solution yet other
than the kludge above.  I hope this helps.
Comment 6 Mike A. Harris 2001-03-28 01:24:24 EST
*** Bug 32399 has been marked as a duplicate of this bug. ***
Comment 7 Martin Høy 2001-03-28 11:26:47 EST
1. You probably mean version 1.1.15 of the driver.
2. That version (1.1.15) was also included in XFree86-4.0.2.
3. Thus: The new XFree86-4.0.3-rpms from rawhide changes nothing.

StarOffice still crashes without the magic env-variable. The reason can probably
be found in the openoffice source code. I have looked at it and talked with the
developer of the driver.
Comment 8 Mike A. Harris 2001-03-28 13:58:55 EST
Yes I mean 1.1.15, but it was not included with XFree86 4.0.2.
Take stock 4.0.2 or 4.0.3 and diff them with either of the authors
last 2 patches, and they are not the same.  The difference between
1.1.14 (which I was applying) and 1.1.15 is the shrinking of one file.

The bug persists, so one will have to work around it as above until the
driver author fixes this, and it is available on his website or in the
core XFree86 distribution.  I've updated to the 1.1.15 driver and a small
patch, which I've not released RPM's of yet.
Comment 9 Mike A. Harris 2001-04-19 11:44:37 EDT
The 4.0.3-9 package in rawhide and on my personal space at
ftp://people.redhat.com reverts a savage patch that caused some problems
for some people.  Not sure if it fixes this problem or not.
Comment 10 Ricardo Ariel Gorosito 2001-04-24 18:29:22 EDT
Bad news:
With XFree86-4.0.3-9 (from ftp://people.redhat.com) on RH71 the machine freezes
completely in StarOffice 5.2 install.
My video card is a S3 Savage 4 (on board-IBM 300GL).
Comment 11 Ricardo Ariel Gorosito 2001-04-25 13:06:00 EDT
In OpenOffice install (build 625) the machine freezes. (XFree86-4.0.3-9 / RH71 /
S3 Savage 4)
Comment 12 Piet E Barber 2001-05-23 11:00:09 EDT
The environment variable set (SAL_DO_NOT_USE_INVERT50=true) DOES work.  YES! 
Woo Hoo!  I was able to load Star Office correctly without massive
crashification after the environment variable was set. 

I'll test it out with the openoffice version, too -- since the bug exists on
that version of StarOffice, too. 

http://www.openoffice.org/issues/show_bug.cgi?id=863
Comment 13 Need Real Name 2001-09-25 04:56:28 EDT
Same problem here with an  "ATI Technologies Inc 3D Rage Pro" card on a 4.1.0 
X-Server on a RedHat 7.1 with a 2.4.3-12 kernel. In my case, the 
SAL_DO_NOT_USE_INVERT50 variable does NOT work: installation starts, displays 
glibc version, and then freezes. The freeze is complete, even telnetting in 
from another box won't work.
OpenOffice version is 633.
Comment 14 incze 2001-10-13 10:29:21 EDT
The very same experience as the 2001-09-25 04:56:28, openoffice-rh@alk.org.lu
comment on different hardware. On Openoffice 638c installation:
No hangup, but the X system does not start, glibc version displayed, snd
the child process that would display the splash screen crashes with
segmentation fault. Right before the fault the process tries to allocate
memory (may be frm the video card - can't see details):

============================================================================
[pid  4505] read(6,
"\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000-\1\000"..., 1024) = 1024
[pid  4505] fstat64(6, {st_dev=makedev(8, 3), st_ino=132142,
st_mode=S_IFREG|0755, st_nlink=1, st_uid=500, st_gid=500, st_blksize=4096,
st_blocks=512, st_size=254715, st_atime=2001/10/06-22:55:12,
st_mtime=2001/09/18-22:44:46, st_ctime=2001/10/06-22:55:02}) = 0
[pid  4505] getcwd("/tmp/sv001.tmp", 128) = 15
[pid  4505] old_mmap(NULL, 199376, PROT_READ|PROT_EXEC, MAP_PRIVATE, 6, 0) =
0x4183e000
[pid  4505] mprotect(0x41868000, 27344, PROT_NONE) = 0
[pid  4505] old_mmap(0x41868000, 28672, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 6, 0x29000) = 0x41868000
[pid  4505] close(6)                    = 0
[pid  4505] brk(0x80bc000)              = 0x80bc000
[pid  4505] --- SIGSEGV (Segmentation fault)
---===========================================================================
Some auxiliary data:

[root@senorg /root]# uname -a
Linux senorg 2.4.2-2 #1 Sun Apr 8 20:41:30 EDT 2001 i686 unknown
[root@senorg /root]# rpm -q glibc
glibc-2.2.2-10
[root@senorg /root]# free
             total       used       free     shared    buffers     cached
Mem:        513284     507340       5944          0      51104     178228
-/+ buffers/cache:     278008     235276
Swap:       525304          0     525304
[root@senorg /root]# rpm -qa | grep XFree
XFree86-libs-4.0.3-5
...
XFree86-SVGA-3.3.6-38
...
XFree86-4.0.3-5
...
[root@senorg /root]#
The video card is an S3 Trio3D with 4MB video ram. The CPU is a PIII/500Mhz.

--------------------- the proposed workaround doesn't cure the bug -----------
[incze@senorg install]$ env | grep SAL
SAL_DO_NOT_USE_INVERT50=true
[incze@senorg install]$ ./setup
glibc version: 2.2.2
[incze@senorg install]$

Comment 15 Mike A. Harris 2001-10-27 18:02:19 EDT
The Savage driver has been updated in XFree86-4.1.0-5 with
Tim Robert's new Savage driver 1.1.20t, which solves this problem.
This release will be available within a day or so for testing at:

ftp://people.redhat.com/mharris/testing/bleeding-edge
Comment 16 Mike A. Harris 2001-11-02 20:10:02 EST
*** Bug 55619 has been marked as a duplicate of this bug. ***
Comment 17 Mike A. Harris 2001-11-02 20:14:12 EST
Updated summary line to be a bit to help others when doing queries.
Comment 18 Andrew Plumb 2001-11-03 21:47:55 EST
I have verified that the XFree86-4.1.0-5 packages solve the problem (Bug 55619) with 
my T21.

I removed the SAL_DO_NOT_USE_INVERT50=true setting from my environment and 
was able to do the installation to a freshly created account without any problems.

Comment 19 Matthew Galgoci 2001-11-05 10:35:52 EST
Verified that this fix works for the savage3 card I've been using. Installed
star office successfully and ran the "attraction" screen saver on the root
window all weekend without a lockup.

Note You need to log in before you can comment on or make changes to this bug.