Bug 321341 - upd-instroot yum actions wind up in system syslog
upd-instroot yum actions wind up in system syslog
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 373461 426069 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-06 10:42 EDT by Jesse Keating
Modified: 2014-01-21 17:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 14:28:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-10-06 10:42:22 EDT
Now that yum logs when it installs/removes things to the system log, actions
done on behalf of upd-instroot are winding up in the system log.  I'm not sure
if this should be "fixed" in upd-instroot or if yum should avoid logging if
--installroot  is used.
Comment 1 Jeremy Katz 2007-10-09 11:46:32 EDT
There's nothing we can do about it in upd-instroot as it stands.  Seth -- does
it make sense to just allow disabling the syslogging?  Or should we do something
more clever
Comment 2 Seth Vidal 2007-10-09 19:33:17 EDT
I'd say leave the logging on and just add the option of listing the installroot
in  the log output if it is NOT '/'

I think Icon submitted a patch for something like that a long time back and it
just got passed over. so something like:
Oct  5 10:57:33 cutter yum: Installed: zsh - 4.3.4-3.fc8.i386 - /my/chroot/

that way they're tracked and easy to distinguish.


Comment 3 Jesse Keating 2007-11-09 14:19:09 EST
*** Bug 373461 has been marked as a duplicate of this bug. ***
Comment 4 Seth Vidal 2007-12-06 22:15:50 EST
After talking about this on yum-devel the rough consensus was 'god this sucks
there's no nice answer' and we shelved it for a while. I think the easiest thing
might be just to turn off syslog/filelog in certain events.
Comment 5 Michael E Brown 2007-12-18 02:27:23 EST
*** Bug 426069 has been marked as a duplicate of this bug. ***
Comment 6 Michael E Brown 2007-12-18 02:27:55 EST
Pretty please can we get this one fixed soon?
Comment 7 Seth Vidal 2008-03-12 10:54:55 EDT
YUMBUGDAY
Comment 8 Bug Zapper 2008-05-13 23:20:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Jan Hutař 2008-08-06 09:31:31 EDT
What about adding "--disable-logging" option?
Comment 10 James Antill 2009-03-06 14:28:57 EST
 Ok this is now fixed upstream. You can specify a syslog_device as part of YumBase().preconf ... if that doesn't exist, then syslogging isn't setup.

Note You need to log in before you can comment on or make changes to this bug.