Bug 325871 - Upgrading F7 to F8 Test 3 leaves dead grub entry from the prevoius OS
Upgrading F7 to F8 Test 3 leaves dead grub entry from the prevoius OS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 242047 345481 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-10 03:36 EDT by Dawid Zamirski
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 12:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Zamirski 2007-10-10 03:36:36 EDT
Description of problem:
I have upgraded my F7 to F8 Test 3 and chose to create a new boot loader
configuration during install. During the first reboot after update, the system
didn't boot successfully due to obsolete grub entry left after previous system
which was pre-selected by default (error message stated that the kernel image
cannot be found). After manually choosing the new F8-base kernel from the boot
menu the system started sucessfully. I was able to reproduce this issue on two
different computers that were originally running Fedora 7.

Version-Release number of selected component (if applicable):
anaconda-11.3.0.36-1

How reproducible:
Reproduces on two different computers. Cannot test it with rawhide image because
after the upgrade I don't have my F7 installations anymore :)

Steps to Reproduce:
1. Select Upgrade option during F8 Test 3 installation.
2. Choose to create a new boot loader configuration.
3. After upgrade process is complete, system won't start as the kernel entry
from previous system is present and automatically selected in the grub boot menu.
  
Actual results:
Cannot find kernel image error message

Expected results:
Boot the new system's kernel. Old kernel entry should be erased as the old
kernel no longer exists.
Comment 1 Jeremy Katz 2007-10-22 16:29:58 EDT
*** Bug 345481 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2007-10-22 19:41:52 EDT
Fixed in CVS
Comment 3 Jeremy Katz 2007-10-22 20:08:08 EDT
*** Bug 242047 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.