Bug 242047 - Anaconda creates incorrect grub.conf when upgrading
Anaconda creates incorrect grub.conf when upgrading
Status: CLOSED DUPLICATE of bug 325871
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
:
: 242053 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 09:30 EDT by Simon Andrews
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 20:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The grub.conf file created by anaconda during update to F7 (676 bytes, text/plain)
2007-06-01 09:32 EDT, Simon Andrews
no flags Details
anaconda.log written at update time (21.65 KB, text/plain)
2007-06-04 16:13 EDT, Bob Gustafson
no flags Details
/root/upgrade.log (52.88 KB, text/plain)
2007-06-04 16:14 EDT, Bob Gustafson
no flags Details
Anaconda log (as requested) (18.87 KB, text/plain)
2007-06-07 07:18 EDT, Simon Andrews
no flags Details
Upgrade log (as requested) (19.67 KB, text/plain)
2007-06-07 07:19 EDT, Simon Andrews
no flags Details

  None (edit)
Description Simon Andrews 2007-06-01 09:30:13 EDT
Description of problem:
When upgrading a machine from fully up to date FC6 the default grub.conf created
contained a FC6 kernel stanza as the default.  This would then not boot on
restart and the F7 kernel had to be manually selected

Version-Release number of selected component (if applicable):


How reproducible:
Not sure.


Steps to Reproduce:
1. Take a fully up to date FC6
2. Update to F7
3. Try to boot the new F7 install
  
Actual results:
The initial boot fails (file not found) and the user has to go back to grub to
select the F7 kernel.

Expected results:
Boot proceeds normally

Additional info:
During the upgrade anaconda reported that it couldn't modify the existing
grub.conf and would have to create a new one.  I selected all of the defaults
for the grub installation.  This is a single boot machine which just had FC6 on
it before.
Comment 1 Simon Andrews 2007-06-01 09:32:44 EDT
Created attachment 155875 [details]
The grub.conf file created by anaconda during update to F7
Comment 2 Bob Gustafson 2007-06-01 10:32:44 EDT
See also bug 24043

Did you also have Raid and volume groups?
Comment 3 Bob Gustafson 2007-06-01 10:34:54 EDT
See also bug 242043

(corrected from previous posting)

Did you also have Raid and volume groups?
Comment 4 Simon Andrews 2007-06-01 10:44:16 EDT
No RAID or volume groups on my server.  Once the F7 kernel was selected it all
booted fine.  That said the two bugs may be related.

Having just updated another server the error seems to stem from the Grub config
options in the update.  Anaconda runs through the full set of options, including
trying to detect other installations on the machine.  At this point it seems to
pick up the FC6 install which is about to be replaced and adds that as the
default entry in the new grub file.  By the time it comes round to being used
the FC6 install has been upgraded and therefore won't boot.

I'd suspect it's the invocation of the code to create a new grub.conf during an
update rather than a fresh install which causes this.  Anaconda needs to
recognise the install which it's about to replace and not offer that as an
additional grub line.
Comment 5 Bradley 2007-06-01 10:53:46 EDT
*** Bug 242053 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2007-06-04 14:09:07 EDT
Can you attach /var/log/anaconda.log and /root/upgrade.log?
Comment 7 Bob Gustafson 2007-06-04 16:13:25 EDT
Created attachment 156120 [details]
anaconda.log written at update time

I hope you are reading the comments and fixes in the other related bug reports

bug 241949 and bug 237415
Comment 8 Bob Gustafson 2007-06-04 16:14:45 EDT
Created attachment 156122 [details]
/root/upgrade.log 

See above above request
See above comment
Comment 9 Simon Andrews 2007-06-07 07:18:48 EDT
Created attachment 156448 [details]
Anaconda log (as requested)
Comment 10 Simon Andrews 2007-06-07 07:19:29 EDT
Created attachment 156449 [details]
Upgrade log (as requested)
Comment 11 Simon Andrews 2007-06-07 07:20:25 EDT
Adding a non-attachment comment to get this bug out of NEEDINFO (I've reported
this bug before but it still seems to be broken!)
Comment 12 Jeremy Katz 2007-10-22 20:08:07 EDT
Fixed this up for Fedora 8

*** This bug has been marked as a duplicate of 325871 ***

Note You need to log in before you can comment on or make changes to this bug.