Bug 242260 - Rhythmbox notification shows '&apos', etc.
Rhythmbox notification shows '&apos', etc.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
: 244119 247966 (view as bug list)
Depends On: 327871
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 16:07 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.11.2-10.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 18:59:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-06-02 16:07:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2007-06-02 16:09:37 EDT
[Sorry for the premature post....]

Rhythmbox notifications do not correctly 'render' special text characters.  I
see '&apos', for example.
Comment 2 Bastien Nocera 2007-06-04 04:58:51 EDT
Which version of rhythmbox are you using?
Could you double-check that the file metadata shows up properly in the Rhythmbox
database as well?
Comment 3 Tom London 2007-06-04 09:33:13 EDT
[tbl@localhost ~]$ rpm -q rhythmbox
rhythmbox-0.11.0-4.fc8
[tbl@localhost ~]$ 

To be precise, I'm listening to 'iradio' station at 'www.folkalley.com', and I
have 'notifications' enabled.

At each new song, a notification pops up with the artist and title.

The notification displays '&apos' if the title has embedded apostrophe (that is
encoded as '&apos').  After the notification window disappears, if you put the
cursor over the rhythmbox icon, a popup appears with the artist/title, but this
time, properly display (i.e. '&apos' is replaced with a single ' character).

Here is what I found in /home/tbl/.gnome2/rhythmbox/rhythmdb.xml (am I looking
in the right place)?

  <entry type="iradio">
    <title>http://www.folkalley.com/fa-members-only.pls</title>
    <genre>Folk</genre>
    <artist></artist>
    <album></album>
    <location>http://www.folkalley.com/fa-members-only.pls</location>
    <play-count>193</play-count>
    <last-played>1180888628</last-played>
    <date>0</date>
    <mimetype>application/octet-stream</mimetype>
    <mb-trackid></mb-trackid>
    <mb-artistid></mb-artistid>
    <mb-albumid></mb-albumid>
    <mb-albumartistid></mb-albumartistid>
    <mb-artistsortname></mb-artistsortname>
  </entry>

Comment 4 Bastien Nocera 2007-06-11 05:52:23 EDT
I believe that the problem is due to:
- a bug in notification-daemon
- the radio pushing the song titles escaped (which you can verify by running
"rhythmbox -d" and capturing the output)

The notification-daemon bug is mentioned at:
http://bugzilla.gnome.org/show_bug.cgi?id=445659
Comment 5 Tom London 2007-06-11 10:49:16 EDT
OK.  Here is output fragment from 'rhythmbox -d'.

Notice '&apos' on last line.

(07:43:31) [0x90f1478] [rb_streaming_source_set_streaming_title]
rb-streaming-source.c:391: streaming title: "Wailin' Jennys (live) - Begin"
(07:43:31) [0x90f1478] [rb_shell_player_sync_with_source]
rb-shell-player.c:2490: playing source: 0x96a5000, active entry: 0x971c360
(07:43:31) [0x90f1478] [streaming_title_request_cb] rb-streaming-source.c:256:
returning streaming title "Wailin' Jennys (live) - Begin" to extra metadata request
(07:43:31) [0x90f1478] [rb_shell_player_sync_with_source]
rb-shell-player.c:2506: got streaming title "Wailin' Jennys (live) - Begin"
(07:43:31) [0x90f1478] [rb_shell_set_window_title] rb-shell.c:2135: setting
title to "Wailin' Jennys (live) - Begin
(http://www.folkalley.com/fa-members-only.pls)"
(07:43:31) [0x90f1478] [streaming_title_request_cb] rb-streaming-source.c:256:
returning streaming title "Wailin' Jennys (live) - Begin" to extra metadata request
(07:43:31) [0x90f1478] [rb_header_sync] rb-header.c:355: syncing with entry =
0x971c360
(07:43:31) [0x90f1478] [streaming_title_request_cb] rb-streaming-source.c:256:
returning streaming title "Wailin' Jennys (live) - Begin" to extra metadata request
(07:43:31) [0x90f1478] [tick_cb] rb-shell-player.c:3063: tick:
[http://www.folkalley.com/fa-members-only.pls, 5067:0(0)]
(07:43:31) [0x90f1478] [rb_tray_icon_notify] rb-tray-icon.c:710: doing notify:
Wailin&apos; Jennys (live) - Begin

Comment 6 Bastien Nocera 2007-06-11 10:53:34 EDT
So it's a bug in the Bubble theme of the notification-daemon, as it will escape
already escaped text.
Comment 7 Bastien Nocera 2007-06-13 18:51:34 EDT
*** Bug 244119 has been marked as a duplicate of this bug. ***
Comment 8 Bastien Nocera 2007-07-12 08:49:55 EDT
*** Bug 247966 has been marked as a duplicate of this bug. ***
Comment 9 Martin Jürgens 2007-07-14 10:06:39 EDT
Confirmed. :)
Comment 10 Matthias Clasen 2007-10-02 11:13:40 EDT
Nope, this is actually rhythmboxes fault. The notification spec explicitly
supports markup in the body, but not in the summary.
Comment 11 Bastien Nocera 2007-10-11 11:40:08 EDT
Fixed in rhythmbox-0.11.2-10.fc9 and rhythmbox-0.11.2-9.fc8
Comment 12 Bastien Nocera 2007-10-11 12:06:42 EDT
Obviously, as I do that, rhythmbox fails to build.
Comment 13 Bastien Nocera 2007-10-11 18:59:19 EDT
Worked-around in libsoup and built now.

Note You need to log in before you can comment on or make changes to this bug.