Bug 329981 - nm-vpn-applet crashes when creating a new OpenVPN connection
nm-vpn-applet crashes when creating a new OpenVPN connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 415921 416841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 16:11 EDT by Sævaldur Arnar Gunnarsson
Modified: 2008-09-29 22:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 22:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the crash (54.42 KB, image/png)
2007-10-12 16:11 EDT, Sævaldur Arnar Gunnarsson
no flags Details

  None (edit)
Description Sævaldur Arnar Gunnarsson 2007-10-12 16:11:07 EDT
Description of problem:
nm-vpn-applet crashes when creating a new OpenVPN connection.
Create a new VPN connection by clicking Add, Select OpenVPN Client and press the
Forward button.
At this time Bug Buddy pops up informing me that my application has crashed and
that information about the crash has been successfully collected (see attached
screenshot).

I can still connect with command line openvpn.
Also I can create vpnc connections through nm-vpn-properties without trouble.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.3.svn2970.fc8
NetworkManager-gnome-0.7.0-0.3.svn2970.fc8
NetworkManager-openvpn-0.3.2-7.fc6
openvpn-2.1-0.19.rc4.fc7

How reproducible:
Always.

Steps to Reproduce:
1.Run nm-vpn-properties
2.Create a new VPN connection by clicking Add
3.Select OpenVPN Client and press the Forward button
4.nm-vpn-properties crashes
  
Actual results:
nm-vpn-properties crashes

Expected results:
I should be able to create OpenVPN connections through nm-vpn-properties

Additional info:
Comment 1 Sævaldur Arnar Gunnarsson 2007-10-12 16:11:07 EDT
Created attachment 226071 [details]
Screenshot of the crash
Comment 2 Ivan Virgili 2007-12-14 13:45:53 EST
Experienced the same problem.
This is from the bug report:

(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_toggle_button_get_active:
assertion `GTK_IS_TOGGLE_BUTTON (toggle_button)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
`GTK_IS_ENTRY (entry)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
`GTK_IS_ENTRY (entry)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_toggle_button_get_active:
assertion `GTK_IS_TOGGLE_BUTTON (toggle_button)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
`GTK_IS_ENTRY (entry)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
`GTK_IS_ENTRY (entry)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_toggle_button_get_active:
assertion `GTK_IS_TOGGLE_BUTTON (toggle_button)' failed
(nm-vpn-properties:6244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
`GTK_IS_ENTRY (entry)' failed
Comment 3 Adam Goode 2007-12-17 11:46:43 EST
*** Bug 415921 has been marked as a duplicate of this bug. ***
Comment 4 Adam Goode 2007-12-17 11:46:56 EST
*** Bug 416841 has been marked as a duplicate of this bug. ***
Comment 5 Robert Scheck 2007-12-17 12:43:25 EST
I don't think, that bug #415921 is really a duplicate. Because here, the crash 
happens at the "Forward" button while it happens for me when trying to fill host
and name input field. Anyway: Fix it, please :)
Comment 6 Adam Goode 2007-12-17 13:34:39 EST
I bet it's a duplicate anyway... all those failed assertions are basically a
minefield that can be triggered at any point.
Comment 7 Sameet 2008-06-08 03:48:59 EDT
I am using Fedora 9 NetworkManager 0.7.0.  I had same problem initially. It
never even went to the screen of asking kind of vpn to be configured.  It turned
out there is a seperate NetworkManager-openvpn-0.7.0.  It now works beautifully
for me.  My system is 
Linux homebaner.net 2.6.25.4-30.fc9.i686 #1 SMP Wed May 21 18:12:35 EDT 2008
i686 i686 i386 GNU/Linux

Hope this was useful.
--sameet

Note You need to log in before you can comment on or make changes to this bug.