Bug 33 - RedHat 5.2 is _NOT_ kernel 2.2 ready.
RedHat 5.2 is _NOT_ kernel 2.2 ready.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 40 132 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-10 21:37 EST by highlander
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-18 09:42:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description highlander 1998-11-10 21:37:00 EST
Somewhere early in the 2.1.x game the network aliasing game
changed.  Net-tools (ifconfig) kept up.  Linuxconf did not.
RedHat 5.1 would hang/stall on boot because of network
aliases.  5.2 just ignores them saying the kernel doesn't
support aliases (2.1.127), which is incorrect.

This was brought to RedHat's attention in the 5.1 period by
myself.  I sought for two months for a remedy before giving
up.  A few people on the newsgroups suggested using 5.0
initscripts.  It worked for them, for some reason it
wouldn't even enable networking for me.

As an angry message I posted to the newsgroups states, I do
not believe RedHat controls the kernel, but when an issue
like this exists and it _IS_ known, it is advertising fraud
to say the distribution is kernel 2.2 ready (or late 2.1.x
ready).

I have two boxes that development kernels would better suit
but cannot put it on because they require 3 and 4 aliases
each.  Again, recap, aliasing interface changed in 2.1.x.
Linuxconf (or any other tool in RedHat) needs to be updated
to detect and deal with it.  Also, kerneld should _NOT_ be
run in anyway 2.1.1xx series or 2.2 kernel.  It is a simple
change to check for.  Below is the fix for the initscript
for kerneld.  Based on 5.1 initscripts.

case "$1" in
  start)
    if [ -f /proc/sys/kernel/modprobe ]; then
        echo "Kerneld unneeded"
        exit 0
    fi
    [ -f /var/lock/subsys/kerneld ] && exit 0

        echo -n "Starting kerneld services: "
        daemon kerneld

        echo
        touch /var/lock/subsys/kerneld
        ;;
  stop)

Trever Adams
highlander@teleteam.net
Comment 1 Preston Brown 1998-11-20 06:47:59 EST
*** Bug 132 has been marked as a duplicate of this bug. ***
Comment 2 David Lawrence 1998-11-20 10:42:59 EST
*** Bug 40 has been marked as a duplicate of this bug. ***
Comment 3 mec 1998-11-20 12:21:59 EST
This, from what I've seen, appears to be 2 seperate bugs -- I have
compiled a kernel with monolithic support for aliasing, and it still
fails.  Kernel aliasing also fails from a kernel compiled (and well
operational) from a 5.1 box.  Now, I'm no kernel hacker, but this
would lead me to believe that there might be some library problems
with 5.2....  Possibly severe?
Comment 4 sdeutsch 1998-11-24 04:38:59 EST
Not only does that not work with the 2.1 kernels but DHCP doesn't work
either!
Comment 5 Cristian Gafton 1998-12-05 12:38:59 EST
DHCP is a knwon issue - it would seem that you only get a binary that
will work either with kernel 2.0 or 2.1, but not both.

Michael, linuxconf is yours, I fixed the initscripts
Comment 6 Preston Brown 1999-03-18 09:42:59 EST
The latest DHCP and BOOTP clients we support are ones that we have
written in house here at Red Hat.  They are available in the RawHide
tree, the package name is 'pump'.  You should be able to build this on
a 5.2 system with a 2.2 kernel and get dhcp/bootp working.
Comment 7 IBM Bug Proxy 2004-09-08 23:15:42 EDT
----- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2004-09-08 23:14 -------
In the interim, Glen please mirror to redhat. 

Note You need to log in before you can comment on or make changes to this bug.