Bug 341751 - multiarch conflicts in kdelibs
multiarch conflicts in kdelibs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 446833 451324 (view as bug list)
Depends On: 349361
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:42 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.1.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 22:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:42:45 EDT
kdelibs4 (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/share/doc/HTML/en/sonnet/index.cache.bz2 from install of kdelibs4-3.93.0-12.fc8 conflicts with file from package kdelibs4-3.93.0-12.fc8
  file /usr/share/kde4/apps/cmake/modules/KDELibsDependencies.cmake from install of kdelibs4-3.93.0-12.fc8 conflicts with file from package kdelibs4-3.93.0-12.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Rex Dieter 2008-02-18 11:14:14 EST
Yuck, those cmake modules are definitely arch-specific.   
I can confirm the sonnect/index.cache.bz2 conflict still exists in 
kdelibs-4.0.1-3 (wasn't a doxygen update supposed to fix that?).


Well, at least we can make the runtime not conflict:

* Mon Feb 18 2008 Rex Dieter <rdieter@fedoraprojectorg> 4.0.1-5
- -devel: include %%_kde4_appsdir/cmake here (#341751)

Comment 2 Bug Zapper 2008-05-13 23:32:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Rex Dieter 2008-05-23 11:08:50 EDT
reassign -> kdelibs
Comment 4 Rex Dieter 2008-05-23 11:09:08 EDT
*** Bug 446833 has been marked as a duplicate of this bug. ***
Comment 5 Rex Dieter 2008-05-23 11:38:35 EDT
confirmed that the actual contents of sonnet/index.cache.bz2 varies from arch 
to arch, trying to sift through a diff here to see what or why.
Comment 6 Rex Dieter 2008-05-23 11:45:15 EDT
html anchor refs are different, dynamically generated I presume.  

Makes me wonder how widespread this problem is or could be, in other kde apps 
that generate index.cache.bz2's.
Comment 7 Rex Dieter 2008-06-13 17:09:46 EDT
*** Bug 451324 has been marked as a duplicate of this bug. ***
Comment 8 Jens Petersen 2008-06-25 04:20:22 EDT
Still true for rawhide too.
Comment 9 Rex Dieter 2008-06-25 14:13:44 EDT
Quick-n-dirty runtime fix,

* Wed Jun 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.83-2
- -common: move %{_kde4_docdir}/HTML/en/sonnet/ here (#341751)

Still have -devel (cmake) issues.
Comment 10 Kevin Kofler 2008-06-25 14:35:27 EDT
Uh, this is a really broken hack. :-/ -common is for files which are used by 
both kdelibs and kdelibs3, which the Sonnet documentation is definitely not.
Comment 11 Rex Dieter 2008-06-25 14:48:39 EDT
Nod, but the only use-case with a downside are folks who have kdelibs3 and not
kdelibs, which is hopefully a small minority.
Comment 12 Bug Zapper 2008-11-25 21:01:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Kevin Kofler 2009-02-15 22:48:13 EST
This has been fixed since forever.
The root issue, i.e. the doc tools being broken, is still unfixed though, causing e.g. bug 485659.

Note You need to log in before you can comment on or make changes to this bug.