Bug 446833 - kdelibs.i386 conflicts with kdelibs.x86_64
kdelibs.i386 conflicts with kdelibs.x86_64
Status: CLOSED DUPLICATE of bug 341751
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 07:45 EDT by Andrey Petrov
Modified: 2008-05-23 11:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 11:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Petrov 2008-05-16 07:45:55 EDT
Description of problem:
You can't yum install kdelibs.i386 on an amd64 Fedora 9 box.

Version-Release number of selected component (if applicable):
kdelibs                 i386       6:4.0.3-7.fc9

How reproducible:
always

Steps to Reproduce:
1. Install 64-bit fedora 9 with KDE.
3. yum install kdelibs.i386
  
Actual results:
Transaction Check Error:
  file /usr/share/doc/HTML/en/sonnet/index.cache.bz2 from install of
kdelibs-4.0.3-7.fc9.i386 conflicts with file from package kdelibs-4.0.3-7.fc9.x86_64

Expected results:
side-by-side kdelibs.amd64 in /usr/lib64 and kdelibs.i386 in /usr/lib

Additional info:
prevents the running of 32-bit kde apps on 64-bit fedora 9
Comment 1 Rex Dieter 2008-05-16 08:15:24 EDT
Joy, more doxygen borkage, it would appear.
Comment 2 Kevin Kofler 2008-05-16 09:19:56 EDT
The workaround is to install the 2 versions in one transaction, which for some 
reason gets RPM not to complain.
su -
rpm -e --nodeps kdelibs
yum install kdelibs kdelibs.i386

But we have to fix this in some way.
Comment 3 Andrey Petrov 2008-05-23 10:24:33 EDT
Same problem with latest F9 KDE updates:
kdelibs-4.0.4-4.fc9.i386
kdelibs-4.0.4-4.fc9.x86_64

I've worked around the problem like this:
# rpm -Uvh --force kdelibs-4.0.4-4.fc9.i386.rpm
(after satisfying all kdelibs.i386 dependencies with yum)
Comment 4 Rex Dieter 2008-05-23 10:40:20 EDT
Maybe move non-arch conflicts to kdelibs-common ?
(doesn't solve conflict in kdelibs4 for previous releases tho)

or maybe some other "common" type subpkg.

noticed with kdelibs-4.0.4 that
/usr/share/kde4/apps/kjava/kjava.jar
conflicts too.
Comment 5 Rex Dieter 2008-05-23 11:08:57 EDT
nevermind, I reconfirmed that kjava.jar was bogus (a local botch).
Comment 6 Rex Dieter 2008-05-23 11:09:07 EDT

*** This bug has been marked as a duplicate of 341751 ***

Note You need to log in before you can comment on or make changes to this bug.