Bug 343711 - hts-5.1-3 does not find cciss storage
hts-5.1-3 does not find cciss storage
Status: CLOSED DUPLICATE of bug 273321
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 23:33 EDT by Rick Hester
Modified: 2008-07-16 17:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 09:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Hester 2007-10-19 23:33:56 EDT
Description of problem:
The hts-5.1-3 beta does not identify cciss (Smart Array)  storage
when hts plan is run.  This is widely used storage and is core 
on several systems

Version-Release number of selected component (if applicable):
hts-5.1-3.EL

How reproducible:
100% on a system with cciss storage

Steps to Reproduce:
1.Install hts-5.1-3 onto a system with cciss storage
2. Run hts discover and hts plan
3. Use hts print --report summary to show that storage has not been 
   identified
  
Actual results:


Expected results:


Additional info:
(see also the issue tracker: 
https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=131503

This problem does not appear to have been fixed in hts-5.1-3.el5.

In fact, the workaround described in bugzilla
https://bugzilla.redhat.com/show_bug.cgi?id=273321
does not seem to work in hts-5.1-3.el5 either:

STEP 3)
[root@max1-pr ~]# mv /var/hts/*.xml .
[root@max1-pr ~]# ls
anaconda-ks.cfg  install.log.syslog                       rhel5.1cert
config.xml       max1-pr.ruby.test.2007101413141.tar.bz2  SetupCert
hts-5.1-3        package.log
install.log      plan.xml

STEP 4)
[root@max1-pr ~]# hts plan
process 4101: Applications must not close shared connections - see
dbus_connection_close() docs. This is a bug in the application.
normal
Hardware: Red Hat unknown ParaVirt Guest
OS: Tikanga 5.1
saved configuration to /var/hts/config.xml
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-52.el5
Created a new plan with 8 tests on 50 devices
saved test plan to /var/hts/plan.xml

STEP 5)
[root@max1-pr ~]# ls /dev/cciss
c0d0  c0d0p1  c0d0p2  c0d1  c0d2
[root@max1-pr ~]# hts plan --add --test storage --device cciss/c0d1
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
Warning: unknown device: cciss/c0d1
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-52.el5
Added test
saved test plan to /var/hts/plan.xml
[root@max1-pr ~]#

STEP 6)

[root@max1-pr ~]# hts print --report summary
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
.
.
.
+-------- System Info Section End --------+



----test device is cciss/c0d1----

*** Testing buffered filesystem (ext3) performance on cciss/c0d1
Error: can not make the mount dir.
...finished running ./storage.py, exit code=1
recovered exit code=1
hts-report-result /HTS/hts/storage FAIL /var/log/hts/runs/3/storage/output.log
saveOutput: /var/log/hts/runs/3/storage/output.log
Return value was 0
running info on /org/freedesktop/Hal/devices/computer
mkdir -p /tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info
cp -a testinfo.desc runtest.sh info.py Makefile
/tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info
install -m 0755 runtest.sh /tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info
make OUTPUTFILE=/var/log/hts/runs/3/info/output.log RUNMODE=normal
UDI=/org/freedesktop/Hal/devices/computer DEVICE= TESTSERVER=unknown run
chmod a+x ./runtest.sh ./info.py
./runtest.sh
/tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info/info.py
Running ./info.py:
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-52.el5
+ rpm -ql kernel-xen-2.6.18-52.el5
Checking Kernel: PASS
Checking Modules: PASS

.
.

Red Hat Hardware Certification test
--------------------------------------------
Test Suite:    5.1    Release: 3
Plan Created:  2007-10-14 01:36:50
Test Server:   unknown
--------------------------------------------

Run: 1 on 2007-10-14 01:42:00
--------------------------------------------
Tests: 9 planned,  2 run, 1 passed, 1 failed
--------------------------------------------


Test Run 1
----------------------------------------------------------------
usb                                                  -
network eth1    net_00_15_60_04_d7_f5                -
network eth0    net_00_15_60_04_d7_f4                -
memory                                               -
cdrom   scd0    storage_serial__NEC_DVD__RW_ND_6650A_A60020000001 -
core                                                 -
info                                                 - PASS
video           pci_1002_5159                        -
storage cciss/c0d1                                      - FAIL

Combined Results for 1 Runs:
--------------------------------------------
  9 tests planned
  2 tests run
  1 tests always failed
  1 tests always passed
[root@max1-pr ~]#
Comment 1 Greg Nichols 2007-10-22 09:02:55 EDT

*** This bug has been marked as a duplicate of 273321 ***

Note You need to log in before you can comment on or make changes to this bug.