Bug 273321 - hts does not see cciss storage
hts does not see cciss storage
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All All
urgent Severity urgent
: ---
: ---
Assigned To: YangKun
:
: 343711 351121 (view as bug list)
Depends On:
Blocks: 223107
  Show dependency treegraph
 
Reported: 2007-08-31 17:37 EDT by Doug Chapman
Modified: 2010-10-22 14:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: hts-5.1-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 02:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of hal-device (48.89 KB, application/octet-stream)
2007-09-06 12:43 EDT, David Aquilina
no flags Details
sosreport from affected system (2.22 MB, application/x-bzip2)
2007-09-06 12:48 EDT, David Aquilina
no flags Details
test results from hts-5.1-3 info test (389.34 KB, application/octet-stream)
2007-10-25 18:50 EDT, Rick Hester
no flags Details

  None (edit)
Description Doug Chapman 2007-08-31 17:37:58 EDT
Description of problem:
The recent versions of hts do not see storage on cciss devices.  During RHEL5.0
certification running hts-5.0-32 it saw the devices but -48 and -50 do not.  I
did not go through all interim versions to determine where this regressed.



Version-Release number of selected component (if applicable):
hts-5.0-48


How reproducible:
100%

Steps to Reproduce:
1. hts discover
2. hts plan
3. hts print --report plan

If the above is done on a system with cciss storage (i.e. devices under
/dev/cciss/c0d0*) those devices do not show up and the storage tests do not run.
 The new HP servers typically only have cciss storage by default.

  
Actual results:


Expected results:


Additional info:
Comment 1 Rick Hester 2007-08-31 19:23:44 EDT
I'm bumping the severity of this up a bit because cciss storage is standard on
several of our boxes so it is important that the certification works for these
devices.
Comment 2 Issue Tracker 2007-09-06 12:39:31 EDT
[root@rx2620 ~]# rpm -q hts
hts-5.0-50.el5
[root@rx2620 ~]# hts print --report plan
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml

Test Plan:
----------------------------------------------------------------
usb                                                        
network    eth1       net_00_0e_7f_7e_0e_ff                
network    eth0       net_00_0e_7f_7e_0e_fe                
memory                                                     
video                 pci_1002_5159                        
info                                                       
cdrom      hda        storage_model_HL_DT_ST_DVD_RW_GCA_4040N 
core                                                       

after removing hts-5.0-50, along with /var/hts, and installing hts-5.0-32
and rerunning the discovery and plan: 

[root@rx2620 32]# rpm -q hts
hts-5.0-32
[root@rx2620 32]# hts print --report plan
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml

Test Plan:
----------------------------------------------------------------
cdrom      HL-DT-ST DVD+RW GCA-4040N           
storage_model_HL_DT_ST_DVD_RW_GCA_4040N 
usb        Computer                                                  
network    Networking Interface                 net_00_0e_7f_7e_0e_fe 
network    Networking Interface                 net_00_0e_7f_7e_0e_ff 
memory     Computer                                                  
info       Computer                                                  
core       Computer                                                  
storage    Smart Array 64xx                     pci_e11_46           
video      Radeon RV100 QY [Radeon 7000/VE]     pci_1002_5159        



This event sent from IssueTracker by dwa 
 issue 131503
Comment 3 David Aquilina 2007-09-06 12:43:47 EDT
Created attachment 188941 [details]
Output of hal-device
Comment 4 David Aquilina 2007-09-06 12:48:20 EDT
Created attachment 188961 [details]
sosreport from affected system
Comment 5 Ronald Pacheco 2007-09-06 13:30:17 EDT
Raising the sevcerity and priority since HP reports that this is blocking their
cert activities.
Comment 6 YangKun 2007-10-08 03:09:39 EDT
This issue is fixed in HTS5.1 . And currently HTS5.1 is under QE testing. So for
now, I'd suggest you keep using hts-5.0-48, and manually add the cciss device
into testplan like following:
  1) remove other versions of HTS
  2) install hts-5.0-48
  3) remove all ".xml" files under "/var/hts/" (please backup if necessary)
  4) run the command:
        # hts plan
  5) add the cciss storage device:
        # hts plan --add --test storage --device cciss/c0dX
  6) run the storage test:
        # hts certify --test storage

Notice:
  o in step 5), you should change "cciss/c0dX" to the proper device name, and it
should be a "drive's name"(analogus to "sda" for a normal SATA drive etc.), not
a partition's name; 
  o please make sure there're at least one swap partition on "cciss/c0dX" and it
functions well, otherwise the storage test will fail.
Comment 7 Doug Chapman 2007-10-10 15:10:47 EDT
I have verified the workaround and it does indeed do the trick, let me know if
you want me to try out the updated hts suite at some point as well.

Comment 8 Issue Tracker 2007-10-16 15:00:04 EDT
This problem does not appear to have been fixed in hts-5.1-3.el5.

In fact, the workaround does not seem to work in hts-5.1-3.el5 either:

STEP 3)
[root@max1-pr ~]# mv /var/hts/*.xml .
[root@max1-pr ~]# ls
anaconda-ks.cfg  install.log.syslog                       rhel5.1cert
config.xml       max1-pr.ruby.test.2007101413141.tar.bz2  SetupCert
hts-5.1-3        package.log
install.log      plan.xml

STEP 4)
[root@max1-pr ~]# hts plan
process 4101: Applications must not close shared connections - see
dbus_connection_close() docs. This is a bug in the application.
normal
Hardware: Red Hat unknown ParaVirt Guest
OS: Tikanga 5.1
saved configuration to /var/hts/config.xml
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-52.el5
Created a new plan with 8 tests on 50 devices
saved test plan to /var/hts/plan.xml

STEP 5)
[root@max1-pr ~]# ls /dev/cciss
c0d0  c0d0p1  c0d0p2  c0d1  c0d2
[root@max1-pr ~]# hts plan --add --test storage --device cciss/c0d1
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
Warning: unknown device: cciss/c0d1
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-52.el5
Added test
saved test plan to /var/hts/plan.xml
[root@max1-pr ~]#

STEP 6) 

[root@max1-pr ~]# hts print --report summary
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
.
.
.
+-------- System Info Section End --------+



----test device is cciss/c0d1----

*** Testing buffered filesystem (ext3) performance on cciss/c0d1
Error: can not make the mount dir.
...finished running ./storage.py, exit code=1
recovered exit code=1
hts-report-result /HTS/hts/storage FAIL
/var/log/hts/runs/3/storage/output.log 
saveOutput: /var/log/hts/runs/3/storage/output.log
Return value was 0
running info on /org/freedesktop/Hal/devices/computer
mkdir -p /tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info
cp -a testinfo.desc runtest.sh info.py Makefile
/tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info
install -m 0755 runtest.sh /tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info
make OUTPUTFILE=/var/log/hts/runs/3/info/output.log RUNMODE=normal
UDI=/org/freedesktop/Hal/devices/computer DEVICE= TESTSERVER=unknown run
chmod a+x ./runtest.sh ./info.py
./runtest.sh
/tmp/hts-info-zMez1O/mnt/tests/HTS/hts/info/info.py
Running ./info.py:
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-52.el5
+ rpm -ql kernel-xen-2.6.18-52.el5
Checking Kernel: PASS
Checking Modules: PASS

.
.

Red Hat Hardware Certification test
--------------------------------------------
Test Suite:    5.1    Release: 3
Plan Created:  2007-10-14 01:36:50
Test Server:   unknown
--------------------------------------------

Run: 1 on 2007-10-14 01:42:00
--------------------------------------------
Tests: 9 planned,  2 run, 1 passed, 1 failed
--------------------------------------------


Test Run 1
----------------------------------------------------------------
usb                                                  -
network eth1    net_00_15_60_04_d7_f5                -
network eth0    net_00_15_60_04_d7_f4                -
memory                                               -
cdrom   scd0    storage_serial__NEC_DVD__RW_ND_6650A_A60020000001 -
core                                                 -
info                                                 - PASS
video           pci_1002_5159                        -
storage cciss/c0d1                                      - FAIL

Combined Results for 1 Runs:
--------------------------------------------
   9 tests planned
   2 tests run
   1 tests always failed
   1 tests always passed
[root@max1-pr ~]#

I'll attach the cert results package



This event sent from IssueTracker by dwa 
 issue 131503
Comment 9 Greg Nichols 2007-10-22 09:02:56 EDT
*** Bug 343711 has been marked as a duplicate of this bug. ***
Comment 10 YangKun 2007-10-25 11:31:47 EDT
I can not get enough information, could you please run "hts submit" and attach
the result rpm here ?

Thanks
-YK
Comment 11 Rick Hester 2007-10-25 18:50:19 EDT
Created attachment 238141 [details]
test results from hts-5.1-3  info test

This is the info test results run in hts-5.1-3 on an rx6600 with several 
smart array RAID volumes .

The hts plan function did not locate any of the devices.
Comment 12 Rick Hester 2007-10-25 18:51:46 EDT
Here's the output from hts plan

[root@max2 hts]# hts print --report summary
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml

Test Plan:
----------------------------------------------------------------
usb
network    eth1       net_00_1a_4b_06_31_17
network    eth0       net_00_1a_4b_06_31_16
memory
storage    sda        storage_serial_2000c50fffe84c632
storage    sdb        storage_serial_2000c50fffe7834e3
storage    sdc        storage_serial_2000c50fffe78355e
storage    sdd        storage_serial_2000c50fffe783295
storage    sde        storage_serial_2000c50fffe783908
storage    sdf        storage_serial_20010b9ff14126817
storage    sdg        storage_serial_20010b9ff14122f0f
storage    sdh        storage_serial_3600508b40001178d00026000065b0000
storage    sdi        storage_serial_3600508b40001178d0002600006610000
storage    sdj        storage_serial_3600508b40001178d0002600006670000
storage    sdk        storage_serial_3600508b40001178d00026000066d0000
core
cdrom      scd0       storage_serial_TEAC_DV_28E_N_A60020000001
info
[root@max2 hts]#

Comment 13 YangKun 2007-10-26 06:39:28 EDT
fixed this issue in hts-5.1-7
Comment 14 Rick Hester 2007-10-26 09:45:07 EDT
Excellent!

Is hts-5.1-7 available to partners?
Comment 15 Greg Nichols 2007-10-29 08:27:49 EDT
*** Bug 351121 has been marked as a duplicate of this bug. ***
Comment 17 Rick Hester 2007-11-01 18:56:09 EDT
Verified fixed in hts-5.1-11

Note You need to log in before you can comment on or make changes to this bug.