Bug 34412 - 7.0 fresh install fails at start of package copy
Summary: 7.0 fresh install fails at start of package copy
Status: CLOSED DUPLICATE of bug 16686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-03 02:19 UTC by Richard Swacen
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 03:57:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Swacen 2001-04-03 02:19:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


"Error Mounting hdb2: Invalid Argument
Seems related to bugs 20574,26299, and 28192
I may not have formatted partitions beforehand

Reproducible: Always
Steps to Reproduce:
1.Went through normal custom install of i386en from CDROM
2.
3.
	

Actual Results:  install fails with Anaconda dump errmsg: "Error Mounting 
hdb2: Invalid Argument"Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 102816
fsystem: ext2
self: <fstab.GuiFstab instance at 8446f90>
msg: Invalid argument
doFormat: 0
errno: 22
device: hdb2
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Expected Results:  Smooth continuation of installation 

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 102816
fsystem: ext2
self: <fstab.GuiFstab instance at 8446f90>
msg: Invalid argument
doFormat: 0
errno: 22
device: hdb2
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2001-04-03 15:08:14 UTC
It appears you tried to mount /dev/hdb2 as '/' without formatting it first. You
may want to try that, since we require a formatted partition for the install to
work.

Comment 2 Brent Fox 2001-04-03 16:02:23 UTC
Looks like bug 16686.

Comment 3 Brent Fox 2001-04-20 03:57:21 UTC

*** This bug has been marked as a duplicate of 16686 ***


Note You need to log in before you can comment on or make changes to this bug.