Bug 345421 - installing OOo on liveCD/USB hangs machine with ext3 errors
installing OOo on liveCD/USB hangs machine with ext3 errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 443475 450097 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2007-10-22 12:04 EDT by Luis Villa
Modified: 2013-01-08 19:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:20:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Villa 2007-10-22 12:04:38 EDT
Description of problem:

If you install openoffice (at least the combination of -writer, -calc, and
-impress; I have not tried with a more minimal package set) at some point during
the installation the system will hang with ext3 errors in dmesg.

How reproducible:
100%. Seems to hang at slightly different places if I have installed slightly
different package sets, suggesting that this has to do with the system running
out of space.


Steps to Reproduce:
1. boot liveUSB key
2. begin installation of openoffice.org-{writer,calc,impress} (either with yum
or pirut)
3. do 'watch 'dmesg | tail'' in a terminal
4. after the packages finish downloading, while the packages are installing,
watch the terminal fill with ext3 error messages before the system becomes
unresponsive.
  
Expected results:

Doesn't die. :)

Additional info:

Have reproduced with F8 test1, test2, and now rawhide livecd iso from 10-19.

liveusb was created with livecd-iso-to-disk; I have not tried it with an actual
liveCD as I don't have access to a CD drive on this machine.
Comment 1 Jeremy Katz 2007-10-22 13:27:29 EDT
This is caused as we use memory as the backing store for changes to the live
system.  Unfortunately, I don't know of a good way to really detect (to avoid or
warn)... longer term, we want to be able to have the changes persist with
backing on disk which would help with the problem.
Comment 2 Luis Villa 2007-10-22 14:16:48 EDT
Not a huge deal; sort of an edge case, obviously. Thought it was worth
recording, though, in case it was an easy fix.
Comment 3 Matthew Merry 2008-05-25 14:12:04 EDT
I'm hitting this on the RTM version of FC9 as well. I'm using a 250MB overlay
and it appears that once this space is used, I hit this bug as well. This
renders my usb flash drive unbootable and is easy to repro. 

Are there any suggestions on how to either avoid this (besides the obvious dont
use all the overlay) or recover the flash drive? There should be a mechanism to
save a user from bricking the flash drive by running out of space.

If it would help, I can provide log files, ect. Please contact me if this would
help.
Comment 4 Jeremy Katz 2008-05-29 13:08:33 EDT
*** Bug 443475 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2008-05-29 16:30:15 EDT
For Fedora 10, I definitely want to get some sort of "view" into what the
available free space in the overlay looks like as well as give more intelligent
indicators of things going bad.
Comment 6 Jeremy Katz 2008-06-02 13:13:57 EDT
(For my own remembering as much as anything)

We can get information on how much of the overlay is used with 'dmsetup status
live-rw', the fourth field gives us UsedBlocks/TotalBlocks

So some thoughts on what we could do
* Poll at some interval on what the used percentage is.  When you get to a
certain amount (80%, 90%?), give a notification to the user.  Tricky as polling
sucks and the polling has to be done as root.
* Shrink the rootfs based on the size of the snapshot at boot time.  This
wouldn't be 100% as snapshot blocks don't get reused, but it might help.  But
this is a pain as we can't shrink filesystems when they're unmounted
* Switch to using the minimal rootfs always and then resize it based on the
snapshot size.  Same caveats as above, but seems a little more plausible to
implement

I sort of like the second and third options as then we could just rely on fixing
the desktop notification of the problem in general but it still doesn't end up
"fully" fixing things due to dm-snapshot not reusing blocks.
Comment 7 Jeremy Katz 2008-06-05 09:47:56 EDT
*** Bug 450097 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2008-06-13 14:23:54 EDT
Okay, after a bit of hacking and trying different things, I'm pretty convinced
that the only way we can really get to do anything reasonable here is by having
something more than dm-snapshot to use as our overlay like, eg, unionfs.  If we
were able to use unionfs, then we'd just get -ENOSPC when out of space and it
would just be a matter of the normal reporting (and checking via statfs64) of
that as opposed to trying to deal with the weird cases that dm-snapshot bubbles up

Reassigning to kernel for that
Comment 9 Bug Zapper 2008-11-26 03:03:18 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-01-09 02:20:10 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.