Bug 34882 - mpage-2.5.1-5 produces japanese symbols in postscripts
mpage-2.5.1-5 produces japanese symbols in postscripts
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mpage (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 39684 49825 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 10:17 EDT by Olivier Baudron
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 10:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Baudron 2001-04-05 10:17:03 EDT
To reproduce the bug:

# echo ABCimDEF >foo
# mpage -1 -f foo >foo.ps
# gv foo.ps
=> It displays a blank page with ABC*DEF where * is a japanese symbol.

Indeed, the file foo.ps has the following lines:

textfont setfont
kanj setfont
0 780 moveto <696d> show
textfont setfont

Specifying latin1 font with option "-CISO-Latin.1" does not resolve the
problem.

Moreover, the manpages should reflect RedHat files: /usr/local/lib/mpage
should be /usr/share/mpage.
Comment 1 Olivier Baudron 2001-04-05 10:22:37 EDT
It seems bugzilla does not translate 8 bit characters into html.
In my report (line 2) it should read "'em" instead of "im" ('e is an eacute)
Comment 2 Bill Nottingham 2001-04-11 12:19:44 EDT
Will be fixed in 2.5.1-6; thanks!
Comment 3 Bill Nottingham 2001-05-08 11:54:50 EDT
*** Bug 39684 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2002-01-24 00:37:22 EST
*** Bug 49825 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.