Bug 34882 - mpage-2.5.1-5 produces japanese symbols in postscripts
Summary: mpage-2.5.1-5 produces japanese symbols in postscripts
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mpage   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 39684 49825 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-05 14:17 UTC by Olivier Baudron
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 14:22:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2001-04-05 14:17:03 UTC
To reproduce the bug:

# echo ABCimDEF >foo
# mpage -1 -f foo >foo.ps
# gv foo.ps
=> It displays a blank page with ABC*DEF where * is a japanese symbol.

Indeed, the file foo.ps has the following lines:

textfont setfont
kanj setfont
0 780 moveto <696d> show
textfont setfont

Specifying latin1 font with option "-CISO-Latin.1" does not resolve the
problem.

Moreover, the manpages should reflect RedHat files: /usr/local/lib/mpage
should be /usr/share/mpage.

Comment 1 Olivier Baudron 2001-04-05 14:22:37 UTC
It seems bugzilla does not translate 8 bit characters into html.
In my report (line 2) it should read "'em" instead of "im" ('e is an eacute)

Comment 2 Bill Nottingham 2001-04-11 16:19:44 UTC
Will be fixed in 2.5.1-6; thanks!

Comment 3 Bill Nottingham 2001-05-08 15:54:50 UTC
*** Bug 39684 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2002-01-24 05:37:22 UTC
*** Bug 49825 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.