Bug 35176 - While reading the package, an internal error occurred.
While reading the package, an internal error occurred.
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-08 07:41 EDT by Andrew Park
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-16 18:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Park 2001-04-08 07:41:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)


After downloading linux 7.0 from RedHat FTP site, I made the boot 
diskette, using the boot image and rawrite from the site. However, when I 
started installation, after creating a user account, an internal error 
occured during the process of reading the package.

Reproducible: Always
Steps to Reproduce:
1. Boot from a floppy, or start installation using autoboot.bat
<Then the rest didn't matter much, because I tried using different options 
and different partitioning methods, ranging from using PartitionMagic to 
make Linux partitions to letting Druid create the partitions>

Actual Results:  Same exact error for maybe 4~5 times.

The Error Message:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: at

Local variables in innermost frame:
self: <comps.HeaderList instance at 824e7b8>
item: at

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 1 Brent Fox 2001-04-09 16:16:54 EDT
Since this is a hard drive install, how did you do the download?  Did you
download the iso images to your hard drive and then do an install?  Also, are
you sure that you did the download in binary format?  This bug looks similar to
bug #21675 and bug #18019.
Comment 2 Adrian 2001-04-13 04:39:47 EDT
I'm experiencing the same problem..... The response listings to the availiable 
anaconda patch show the true extent of this problem.... there are many users 
who have downloaded the RPMS and base files from FTP servers and had the same 
subsequent error when trying to install....

The anaconda fix update simply doesn't seem to work...
Comment 3 Brent Fox 2001-04-16 18:03:50 EDT

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.