Bug 353721 - No fonts for the Romanian national characters
No fonts for the Romanian national characters
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dejavu-lgc-fonts (Show other bugs)
5.4
All Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
desktop-bugs@redhat.com
http://www.secarica.ro
:
Depends On:
Blocks: 329071 337271 376231
  Show dependency treegraph
 
Reported: 2007-10-26 04:33 EDT by Răzvan Sandu
Modified: 2008-05-08 13:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 14:32:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-10-26 04:33:38 EDT
Description of problem:

There are no fonts to correctly represent 4 characters in the Romanian national
set (neither in text mode nor in X mode).

A correct implementation should use the comma-versions of "s" and "t" (please
see bug #329071), namely:

- "S with comma below" (Unicode 0218)
- "s with comma below" (Unicode 0219)
- "T with comma below" (Unicode 021A)
- "t with comma below" (Unicode 021B)

At these time, when setting the system for Romanian language, (incorrect)
cedilla versions of "s" and "t" are used.

Version-Release number of selected component (if applicable):
fonts-ISO8859-2-1.0-18.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Install a fresh Red Hat or Fedora system.
2. During install, ask for Romanian as default language and Romanian keyboard.
3. Observe that incorrect cedilla-version of the fonts are used, instead of the
comma ones.
4. Things cannot be corrected/changed right now because there are no fonts to
represent the Romanian national characters correctly (please see bug #329071).
5. A correct keyboard implementation for the Romanian layout is not possible at
this time, since there is no font to represent the Romanian-specific characters
with commas.


Actual results:

There are no fonts to represent the Romanian-specific characters (UTF-8):

"s with comma below"
"t with comma below"
"S with comma below"
"s with comma below"

neither in text mode nor in X.

Expected results:

When configured for Romanian language, the system should contain by default the
appropriate fonts for the comma versions of characters (UTF-8) and should use
them all over (in text mode and in X).

Additional info:

In Romanian:
http://www.secarica.ro
http://diacritice.sourceforge.net/tastaturi.html
Comment 1 Rahul Bhalerao 2007-11-12 06:58:57 EST
Does this means that, the characters are present and shown but have wrong
shapes(I guess the bottom part only)? 
Comment 2 Alexandru Szasz 2007-11-12 07:19:03 EST
I'm a bit confused as there are fonts in X that do contain the correct
characters for the romanian language. Also there is a correct romanian keymap in
X. And Fedora/Redhat packs X from xorg so is this really an issue ?

I'm working on another bug 253892 to include a font for the TEXT mode. There
isn't one now that contains the correct characters. Is that what's reported
wrong here ?
Comment 3 Răzvan Sandu 2007-11-12 15:02:47 EST
Hello,


Here's the piece of information Rahul asked for in comment #1:


IMHO, there is a chain of issues here (please see comments to the other related
bugs too):

- there is no font to represent correctly some of the Romanian-specific
characters (the correct s,t, S, T with comma below instead of the incorrect s,t,
S, T with cedilla below);

- because of this, there is no correct implementation for the Romanian keyboard
(by "correct implementation" I mean one that a. reflects the layout of the
physical Romanian keyboards and b. generates s and t with comma below)

- because of the above, there are various confusions and incompatibilities in
all programs, both in text mode and X - some programs use cedilla characters
instead of their comma counterparts, there are incompatibilities even in
Unicode-aware programs, crashes in anaconda (see bug #376231), etc.

Someone please:

- drop for good those cedilla s and t, which *doesn't* exist in Romanian
language (it's a historical mistake that has been propagated);

- create a font with s and t with comma (or include it in Fedora, if it already
exist), with the proper Unicode codes (see correct codes above);

- use the new font with s and t with comma as *default font* for Romanian
language, in all programs, in both text and X mode;

- allow for the creation of the correct two arrangements for the Romanian
keyboard, as established by the Romanian official standard (please see bug #337271).

- update anaconda and system-config-keyboard to correctly take into account the
new settings for Romanian, in both text mode and X.


IMHO, the *default* arrangement for the Romanian keyboards in any Linux
distribution should be the one designated as "secondary" in the national
standard, since it can be used more easily even when one don't have a *physical*
Romanian keyboard, but an English-US one.



Many thanks,
Răzvan
Comment 4 Alexandru Szasz 2007-11-13 02:21:32 EST
For the text mode, solutions are presented in bug 253892.

For X, the only thing to do now is to make the comma variant the default one.
But that is a thing to do in xorg (xkb actually), not here. In X there are fonts
and there are keymaps with cedilla as well as with comma.
Comment 5 Rahul Bhalerao 2007-11-14 06:45:34 EST
The glyphs for the Romanian characters mentioned here actually come from Dejavu
and bitmap fonts. ISO8859-2 encoding itself does not cover these characters,
thus fonts-ISO8859-2 does not have glyphs for them. Thus I am reassigning the
bug to DejaVu fonts. 

As far as fonts are concerned the glyphs in DejaVu font are incorrect. Unicode
has encoded the said characters with  bottom 'comma' on the expected code
points. Thus there is no issue about encoding at all. Its only a font issue.

Secondly, bitmap fonts are available for text mode usage. But I don't think its
possible to improve the shapes for the bitmaps any further due to the
limitations of resolution. 

I could not find the keyboard layout in scim for Romanian. If that is the case,
there should be separate bug filed against scim for having the required tables.

Lastly, since ISO8859-2 does not cover these Romanian characters, I don't think
the fonts-ISO8859-2 should be included in comps for Romanian support. 
Jens, can you help on that?
Comment 6 Alexandru Szasz 2007-11-14 07:09:14 EST
Actually ISO8859-16 covers Romanian characters, but I don't know if that's shipped.
Comment 7 Rahul Bhalerao 2007-11-15 00:05:12 EST
Atleast not as a part of Romanian Support. But there must be other fonts
covering that range. 
Comment 8 Răzvan Sandu 2008-02-23 11:09:11 EST
Hello,

Can we hope this will be fixed for good in the new versions, say Fedora 9 ?
IMHO, the correct way to follow is that presented in comment #3.

Many thanks,
Răzvan
Comment 9 Behdad Esfahbod 2008-02-24 14:32:11 EST
Please report this against dejavu fonts upstream at:
https://bugs.freedesktop.org/
Comment 10 Behdad Esfahbod 2008-02-24 14:34:33 EST
I checked on F8 and those characters have a comma below, not a cedilla.  So I
think this is already fixed.
Comment 11 Răzvan Sandu 2008-05-08 13:21:03 EDT
The issue about Romanian incorrectly-generated characters was recently corrected
in bug #13277 at freedesktop.org.

Please see comments #82 and #83, with the appropriate patch:

http://bugs.freedesktop.org/show_bug.cgi?id=13277

Would you please include this correction in Red Hat/Fedora ASAP, since it
affects *thousands* of documents and webpages generated in Romanian language ?

Thanks a lot,
Răzvan
Comment 12 Răzvan Sandu 2008-05-08 13:31:16 EDT
This historical bug regarding Romanian language is also corrected in Microsoft
Windows Vista and, by this patch, in Windows XP:

http://www.microsoft.com/downloads/details.aspx?FamilyID=0ec6f335-c3de-44c5-a13d-a1e7cea5ddea&DisplayLang=en

Răzvan

Note You need to log in before you can comment on or make changes to this bug.