Bug 357711 - kernel update 2.6.23.1-10.fc7 breaks resume on Dell Inspiron 9400
kernel update 2.6.23.1-10.fc7 breaks resume on Dell Inspiron 9400
Status: CLOSED DUPLICATE of bug 242234
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 04:28 EDT by J. Ali Harlow
Modified: 2008-01-16 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 18:45:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmidecode (12.13 KB, text/plain)
2008-01-16 15:27 EST, J. Ali Harlow
no flags Details
Output of lspci -vvxxx (36.18 KB, text/plain)
2008-01-16 15:28 EST, J. Ali Harlow
no flags Details
Output of lsmod (3.32 KB, text/plain)
2008-01-16 15:28 EST, J. Ali Harlow
no flags Details
dmesg output just after rebooting with pm_trace enabled (23.93 KB, text/plain)
2008-01-16 17:04 EST, J. Ali Harlow
no flags Details

  None (edit)
Description J. Ali Harlow 2007-10-30 04:28:02 EDT
Description of problem:
Suspend to RAM appears to work correctly, but attempting to resume results in a
black screen (no backlight) at which point the only remedy appears to be a power
cycle.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-10.fc7
(hal-0.5.9-8.fc7)

How reproducible:
Always

Steps to Reproduce:
1. Use "Stand By" metakey to activate suspend to RAM
2. Press power button to resume.
  
Actual results:
After a few seconds of activity, the machine stops with a black screen.

Expected results:
Resumption of previous session

Additional info:
Works fine if I boot the previous kernel (kernel-2.6.22.9-91.fc7).
May well be a duplicate of bug #312981.
Comment 1 J. Ali Harlow 2007-11-06 03:30:03 EST
kernel-2.6.23.1-21.fc7 has the same problem.
Comment 2 Christopher Brown 2008-01-15 22:07:46 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 3 J. Ali Harlow 2008-01-16 02:53:42 EST
Hi,

Yes, still having problems with the latest F7 kernel (kernel-2.6.23.12-52.fc7).

Thanks.
Comment 4 Christopher Brown 2008-01-16 08:23:34 EST
Thanks for the update. Please can you attach contents of:

# dmidecode
lscpi -vvxxx
lsmod

as separate attachments to this bug of type text/plain.

Cheers
Chris
Comment 5 J. Ali Harlow 2008-01-16 15:27:17 EST
Created attachment 291884 [details]
Output of dmidecode

Output of dmidecode running kernel-2.6.23.12-52.fc7
Comment 6 J. Ali Harlow 2008-01-16 15:28:12 EST
Created attachment 291885 [details]
Output of lspci -vvxxx

Output of lspci -vvxxx running kernel kernel-2.6.23.12-52.fc7
Comment 7 J. Ali Harlow 2008-01-16 15:28:54 EST
Created attachment 291886 [details]
Output of lsmod

Output of lsmod running kernel kernel-2.6.23.12-52.fc7
Comment 8 J. Ali Harlow 2008-01-16 15:31:08 EST
Information requested provided (random comment to get status back to NEW).
Comment 9 Christopher Brown 2008-01-16 15:38:04 EST
Thank you for that. Could you take a look at:

http://fedoraproject.org/wiki/KernelCommonProblems

and review the section entitled Suspend/Resume to RAM Failure as this will help
is debug the issue further. In particular running:

pm-suspend ; dmesg > dmesg.out ; sync

as this writes a dmesg.out file which, if you could attach to this bug, would
also help.
Comment 10 J. Ali Harlow 2008-01-16 17:04:31 EST
Created attachment 291899 [details]
dmesg output just after rebooting with pm_trace enabled

Ok, having read that page, I see that that Caps Lock key is non-functional. I
tried to use pm_trace as suggested, but while my date gets corrupted, there are
no entries in dmesg as described. I attach the full dmesg output in case it is
useful.
Comment 11 Christopher Brown 2008-01-16 17:53:06 EST
You could try unloading the iwl3945 module before suspend:

# modprobe -r iwl3945

You may need to being down the network interface first. If you still have the
same issue try also removing the b44 and firewire modules.
Comment 12 J. Ali Harlow 2008-01-16 18:29:15 EST
Removing the b44 module solves the problem. Sadly this kills my network interface!
Comment 13 J. Ali Harlow 2008-01-16 18:45:17 EST
And adding SUSPEND_MODULES="b44" to /etc/pm/config.d/unload_modules fixes the
problem properly so this is a duplicate of bug #242234.

*** This bug has been marked as a duplicate of 242234 ***

Note You need to log in before you can comment on or make changes to this bug.