Bug 358141 - kpowersave crash and logout problems
kpowersave crash and logout problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpowersave (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 363211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 09:15 EDT by Alexei Podtelezhnikov
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.7.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:49:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2007-10-30 09:15:15 EDT
kpowersave is not stable in current pre-F8 rawhide. It seems to crash randomly 
and, in turn, cause logout problems. That is, logout clicks are just ignored 
and cause no visible action. The only way to stop session is to kill it with 
Ctrl-Alt-Bksp. In other words, these logout problems seem to coinside with 
sudden disappearance of kpowersave from KDE panel - not that logout causes 
crash, rather crash causes logout problems.

kpowersave-0.7.3-0.2svn20070828.fc8
hal-0.5.10-1.fc8
kernel-2.6.23.1-37.fc8

How can i try new official kpowersave-0.7.3?
Comment 1 Rex Dieter 2007-10-30 11:27:38 EDT
fwiw, kpowersave worksforme (dell latitude d620)
Comment 2 Alexei Podtelezhnikov 2007-10-31 21:11:06 EDT
I tried kpowersave-0.7.3 (final). Same type of problems persists on Dell Vostro
1500. It seems though that the problem in the final version is more isolated and
less random. kpowersave just refuses to start after some reboots, sometimes
after reboots from Windows. After such failures, it is impossible to logout
gracefully. It all looks like the problem may be in bios or acpi. What is
unfortunate is that kpowersave doesn't leave a trace after a crash or logs its
failures. I would appreciate, if someone taught me how to monitor kpowersave
launches and crashes.

So, I see problems on Dell Vostro 1500 A01. I wish I could provide more details
at this point.

 
Comment 3 Rex Dieter 2007-11-01 23:17:16 EDT
*** Bug 363211 has been marked as a duplicate of this bug. ***
Comment 4 Marcela Mašláňová 2007-11-02 08:29:36 EDT
Hello,
I've dell latitude D830 kpowersave-0.7.3-0.2svn20070828.fc8 and "sometimes" log
out won't work. 
Sometimes I see on log out window with KDE crash (for some application) and than
normal shutdown.

If you need some strace, log whatever let me know.

marcela
Comment 5 Rex Dieter 2007-11-02 08:41:22 EDT
Yes, please, any additional information to help diagnose would be valuable.  If
possible too, would one of the affected parties submit this upstream to
bugs.kde.org as well?
Comment 6 Alexei Podtelezhnikov 2007-11-02 11:55:37 EDT
http://sourceforge.net/tracker/index.php?func=detail&aid=1824718&group_id=124576&atid=700009

KDE folks don't like kpowersave bugs, because it is not a part of kde releases 
or development. So the bug is filed on sourceforge.net. 

Comment 7 Alexei Podtelezhnikov 2007-11-05 08:30:59 EST
This is crazy. I am now pretty certain that nm-applet has a role in this 
failures. I have kpowersave disabled for now, yet my *occasional* logout 
problem reappeared. On log in, I again saw a bouncing "K" for a very long time 
(30 seconds). After it stopped I tried and couldn't log out. In "ps -e"  I saw 
nm-applet, and I decided - what the hell, let's kill it. Voila, the screen has 
deemed and the logout window appeared. So it was nm-applet that blocked my 
logout.

Now, I tend to think that final kpowersave-0.7.3 would actually be a worthy 
update as soon as F8 is out. It did seem to me to work better and never 
crashed in the middle of the session, which cvs snapshot frequently did.

As for nm-applet, seem to have problems with kdm or something. I hope it will 
be resolved in a due course ;)

I will disable nm-applet for now and re-enable kpowersave-0.7.3 final.
Comment 8 Alexei Podtelezhnikov 2007-11-05 18:41:13 EST
kpowersave-0.7.3 from koji works fine so far. So this bug will probably be 
closed soon. Just be aware that some of logout problems are caused by 
nm-applet weirdness, see bug 367711.
Comment 9 Fedora Update System 2007-11-08 01:01:29 EST
kpowersave-0.7.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kpowersave'
Comment 10 John Summerfield 2007-11-08 20:30:49 EST
I have just applied the f8 updates.

kpowersave is not installed:
[root@potoroo ~]# rpm -qa '*power*'
gnome-power-manager-2.20.0-6.fc8
[root@potoroo ~]#

I can't logout from a VNC session, I wish to reboot following the update.

I killed nm-applet, and the logout immediately proceeded.

Note that _my_ original report was 363211
Comment 11 Fedora Update System 2007-11-20 12:49:12 EST
kpowersave-0.7.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.