Bug 367711 - NM-gnome or knetworkmanager, but NOT both!
NM-gnome or knetworkmanager, but NOT both!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 374321 375331 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 18:40 EST by Alexei Podtelezhnikov
Modified: 2007-11-30 17:12 EST (History)
10 users (show)

See Also:
Fixed In Version: 0.2-0.7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 01:03:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2007-11-05 18:40:33 EST
NetworkManager-gnome autostarts nm-applet under KDE. Please stop it.

knetworkmanager should control NM under KDE. Yes, I know it is broken and 
replaced with the same nm-applet for now. The thing is that if you have both 
NM-gnome and knetworkmanager, two instances of nm-applet are attempted with 
very unpredictable results, including blocked logouts, etc. With 
NetworkManager daemon off, it is even weirder. 

Anyway, stop NetworkManager-gnome from starting nm-applet under KDE, please.
Comment 1 Rex Dieter 2007-11-06 09:37:43 EST
nm-applet blocking logouts is a separate issue (bz?).

It is my strong belief that both nm-applet (and knetworkmanager) should be
usable under *any* desktop, so to me, your suggestion isn't compatible with that.

What *is* missing in nm-applet, is an ability for an end-user to disable it, ie,
disable it auto-launching (knetworkmanager has/had that feature).
Comment 2 Alexei Podtelezhnikov 2007-11-06 10:55:27 EST
Do you want two applets launched together by default? As it stands right now,
two nm-applets are attempted to be launched. It is an ugly bug in the default
KDE setup.

Cross-usability is great, but a default user shouldn't be cornered with the two
choices in his face, even when there will be a choice.

We don't want to duplicate everything (or anything) on the default desktop. 

 
Comment 3 Rex Dieter 2007-11-06 11:03:49 EST
If you don't want both, then don't install both.
Comment 4 Rex Dieter 2007-11-06 11:04:43 EST
corrolary: if you *do* install both, the expectation should be to be able to use
both (or either, that's your choice).
Comment 5 Alexei Podtelezhnikov 2007-11-06 12:20:56 EST
It is not like I have a choice.
knetworkmanager depends on NetworkManager-gnome

The latter installs /etc/xdg/autostart/nm-applet.desktop
which is missing X-Gnome-UniqueApplet=true or something.

So you have

/etc/xdg/autostart/nm-applet.desktop
/usr/share/autostart/knetworkmanager-autostart.desktop

both starting the same damn thing.

Am I clear now?

Comment 6 Rex Dieter 2007-11-06 12:33:37 EST
I fail to the a problem, atm.  
Are you seeing 2 instances of nm-applet?  (I don't, it WORKSFORME).

When, the *real* knetworkmanager comes back, then yes, we'll have to have devise
a n upgrade strategy to handle this.
Comment 7 Alexei Podtelezhnikov 2007-11-06 12:51:07 EST
The second launch attempt sometimes blocks logout for me and others:  
https://bugzilla.redhat.com/show_bug.cgi?id=358141#c4 :) 

The fact that the second attempt just does NOTBOTHERYOU doesn't mean that it 
won't SCREWOTHERS. This is a bug in NetworkManager-gnome package.
Even when you update knetworkmanager, nm-applet will continue to autostart on 
KDE. My last comment in this bug, Thanks!
Comment 8 Rex Dieter 2007-11-06 13:01:16 EST
No one is suggesting bugs like what you (and others) seeing shouldn't fixed.
Comment 9 Alexei Podtelezhnikov 2007-11-06 13:17:27 EST
The trivial fix is to add

OnlyShowIn=GNOME

to 

/etc/xdg/autostart/nm-applet.desktop
Comment 10 Rex Dieter 2007-11-06 13:19:23 EST
reassigning -> knetworkmanager
so that we can disable the 2nd (emulated) nm-applet launch.

(OnlyShowIn was reverted, and is not recommended, see bug #336021)
Comment 11 Alexei Podtelezhnikov 2007-11-06 13:43:31 EST
Sorry, I posted before I tried it. With OnlyShowIn=GNOME in nm-applet.desktop 
and knetworkmanager installed, the hell breaks loose. I have no idea how, but 
this interferes with kpowersave(!) and prevents it from starting very 
reproducibly here. 
Comment 12 Roland Wolters 2007-11-06 13:57:22 EST
Strange, I cannot verify this bug:
I installed a fresh copy of Fedora 8 on my system, created an entirely new, 
virgin user, and still, I only have one applet.

Alexei, did that problem come up with an entirely new user on a virgin system 
or did it happen on a system where you upgraded. If the second case is true, 
can you describe the update path?

Btw., Alexei, please be aware that Rex' "WORKSFORME" wasn't an insult or 
screaming but is a set phrase of the bugzilla language.
Comment 13 Alexei Podtelezhnikov 2007-11-06 14:41:48 EST
(In reply to comment #12)
> I only have one applet.
> 

I didn't say that the second applet successfully launches. Most of the time it 
fails. Sometimes it fails with consequences. Sometimes it prevents even the 
first applet from normally starting, sometimes it blocks logouts. 

nm-applet is a very raw application. In addition to the above symptoms, it 
never reports if NetworkManager daemon is not running. It just just fails with 
a different series of unpredictable consequences.

If you combine double-launch with stopped NetworkManager... Oh boy, good luck 
avoiding troubles.
Comment 14 Rex Dieter 2007-11-06 15:32:36 EST
* Tue Nov 06 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.2-0.7
- omit knetworkmanager-autostart, so nm-applet doesn't start twice (#367711)
- omit needless (icon) scriptlets

Comment 15 Rex Dieter 2007-11-06 15:35:09 EST
Alexei,
can you try this build, does it help?
http://koji.fedoraproject.org/koji/taskinfo?taskID=228516 
Comment 16 Alexei Podtelezhnikov 2007-11-06 17:02:56 EST
Ok. This seems to work ok. All applets started fine.
Comment 17 Fedora Update System 2007-11-08 01:03:02 EST
knetworkmanager-0.2-0.7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Greg Martyn 2007-11-12 00:55:45 EST
*** Bug 374321 has been marked as a duplicate of this bug. ***
Comment 19 Jeremy Katz 2007-11-12 10:20:42 EST
*** Bug 375331 has been marked as a duplicate of this bug. ***
Comment 20 Sergio Monteiro Basto 2007-11-12 15:28:39 EST
why knetwork don't use knetwork instead of this horrible of nm-applet that even
don't have a quit button . 
Comment 21 Rex Dieter 2007-11-12 15:33:41 EST
Sergio, knetworkmanager doesn't (yet) work with nm-0.7, see bug #298991

Note You need to log in before you can comment on or make changes to this bug.