Bug 363211 - KDE logout button does not logout
KDE logout button does not logout
Status: CLOSED DUPLICATE of bug 358141
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-01 22:01 EDT by John Summerfield
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 23:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Summerfield 2007-11-01 22:01:06 EDT
Description of problem:

KDE logout button does not logout

Version-Release number of selected component (if applicable):


How reproducible:
Always, for me.

Steps to Reproduce:
1. Install F8t3
2.  Add KDE (I didn't install it at system install time)
3.  Login (I use kdm)
  
Actual results:
Logout button does not work

Expected results:
Logout button to end session

Additional info:
I can't not have the problem. It's a showstopper.
There are no relevant messages in ~/.xsession-errors and nothing in
/var/log/messages
Comment 1 Alexei Podtelezhnikov 2007-11-01 22:20:30 EDT
In my case, this is related to kpowersave, which fails to start properly, but 
succeeds in messing up logout controls in a meantime. You use a laptop, don't 
you?

May I suggest, 'rpm -e kpowersave' temporarily just to confirm this 
possibility by checking how things work (or don't) without kpowersave. You may 
try to prevent it from starting some other way too. Check out my bug 358141.

If kpowersave is a culprit, please share which laptop you use and what the 
bios version is.
Comment 2 Rex Dieter 2007-11-01 23:17:15 EDT

*** This bug has been marked as a duplicate of 358141 ***
Comment 3 John Summerfield 2007-11-02 04:32:09 EDT
It's no kind of laptop, it's an HP DC7700 SFF.

Removing kpowersave eliminates the problem.

Comment 4 Alexei Podtelezhnikov 2007-11-02 08:37:43 EDT
I guess for you it is a fix, because you don't really need kpowersave. I wonder
why you had it installed in a first place.
Comment 5 Rex Dieter 2007-11-02 08:43:05 EDT
kpowersave is installed by default as part of kde-desktop.

For giggles, affected parties could try running gnome-power-manager to see if it
behaves any better.
Comment 6 John Summerfield 2007-11-02 18:53:26 EDT
I did not choose it, it got installed when I installed KDE after the main
installation. I guess it's in the KDE group.


I would expect it to be useful, I believe these machines can hibernate, and if
they don't have power-saving modes, they should have. Battery life isn't the
only reason to save power.
Comment 7 Alexei Podtelezhnikov 2007-11-08 20:54:51 EST
You need to update knetworkmanager as well. See bug 367711.
This will resolve nm-applet-related problems. It was officially updated today.   

Note You need to log in before you can comment on or make changes to this bug.