Bug 36098 - /tmp/cciss/c0d11 - c0d15 have same minor number as c0d1
/tmp/cciss/c0d11 - c0d15 have same minor number as c0d1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 36099 36100 36101 41870 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-16 18:23 EDT by Bryan Leopard
Modified: 2007-03-26 23:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 14:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to be applied to CVS (2.15 KB, patch)
2001-07-19 14:35 EDT, Matt Wilson
no flags Details | Diff

  None (edit)
Description Bryan Leopard 2001-04-16 18:23:04 EDT
during install if you look at the temp device nodes that install is 
creating the device modes c0d11 through c0d15 have the same minor number 
as c0d1 which means they are all pointing to the c0d1 disk.  So install 
will fail when you try to update the partition table of c0d1 because it is 
open 7 times. 
This even occurs with your cciss anaconda update disk.

Compaq would like to see this fixed in your next anaconda update.
Comment 1 Brent Fox 2001-04-16 22:37:06 EDT
*** Bug 36099 has been marked as a duplicate of this bug. ***
Comment 2 Brent Fox 2001-04-16 22:38:14 EDT
*** Bug 36100 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2001-04-16 22:39:05 EDT
*** Bug 36101 has been marked as a duplicate of this bug. ***
Comment 4 Brent Fox 2001-04-16 22:43:19 EDT
It looks like you filed the same bug four times with slight variations.  Did you
mean to file this against 7.0 or 7.1?  We have not released an updates disk for
anaconda for Red Hat Linux 7.1.  7.1 was just released today (4/16/2001).
Comment 5 Bryan Leopard 2001-04-17 10:29:54 EDT
These bugs happen with 7.0 and 7.1.  I realize that you just released 7.1 
yesterday, but we wanted to get this to you so that you could include this 
when/if you do an anaconda update in the future.  This bug was seen on 7.0 and 
7.1 and we are checking 6.2.  We would like to see it fixed for 7.0 and 7.1.  
This is not a critical bug since it has been there for at least two releases.  
We have a workaround, but it is not pretty.  
Comment 6 Brent Fox 2001-04-21 19:18:41 EDT
Brock, do we have on of these RAID controllers that use the cciss driver in the
test lab?
Comment 7 Arjan van de Ven 2001-05-15 14:24:57 EDT
How is this a kernel bug?
The kernel doesn't make the devicefiles, anaconda does.
Comment 8 Brent Fox 2001-06-27 14:31:13 EDT
*** Bug 41870 has been marked as a duplicate of this bug. ***
Comment 9 Brent Fox 2001-07-09 18:42:47 EDT
Can you tell me exactly how to reproduce this bug?  I did a test install with a
ProLiant with a SmartArray 5300 of Red Hat Linux 7.1  The machine had three
drives, which I arranged in a RAID 5 configuration.  I created 15 partitions on
that RAID device, did the install of 7.1, and then upgraded to our latest
internal tree, and eveything worked fine.  I must not be doing the same thing
that you are...
Comment 10 Bryan Leopard 2001-07-16 17:12:46 EDT
you only created 15 PARTITIONS 
you need to create 16 LOGICAL VOLUMES on the array ( d0-d15), then they will 
see the problem 

So in your setup create the array, then create 16 logical volumes on that array.
Comment 11 Matt Wilson 2001-07-17 16:21:59 EDT
Is this bug still present in 7.1?  I have not gotten a clear answer.
Comment 12 Matt Wilson 2001-07-17 16:37:15 EDT
oh, I see the bug in the code now.  Fixing.
Comment 13 Bryan Leopard 2001-07-19 12:09:22 EDT
When will we see this fix?
Comment 14 Matt Wilson 2001-07-19 14:35:12 EDT
I'm applying the applied patch to CVS.  It will be included in the next release.
 Fixes to prior releases will need to be scheduled.
Comment 15 Matt Wilson 2001-07-19 14:35:59 EDT
Created attachment 24187 [details]
patch to be applied to CVS
Comment 16 Matt Wilson 2001-07-19 16:27:44 EDT
I'm going to move this to resolved, but not closed, since I've fixed in in HEAD.
Issues on backporting this can continue to be discussed.

Note You need to log in before you can comment on or make changes to this bug.